]> code.ossystems Code Review - openembedded-core.git/commitdiff
eglibc: fix checksums of fetched patches
authorMarko Lindqvist <cazfi74@gmail.com>
Thu, 13 Dec 2012 16:39:22 +0000 (18:39 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 13 Dec 2012 18:02:16 +0000 (18:02 +0000)
As downloaded files are not named, tarball checksum is used also
for downloaded patches, causing checksum check for them to fail.
Added correct checksums of their own for all downloaded files.

Signed-off-by: Marko Lindqvist <cazfi74@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/eglibc/eglibc_2.16.bb

index 973be6535fa0fdf973b637a4c8e138abb14f6c91..c35d94c891fdbe58f34aa83c3030449e71acbbc2 100644 (file)
@@ -3,7 +3,7 @@ require eglibc.inc
 DEPENDS += "gperf-native kconfig-frontends-native"
 PR = "r19"
 
-SRC_URI = "http://downloads.yoctoproject.org/releases/eglibc/eglibc-${PV}-svnr21224.tar.bz2 \
+SRC_URI = "http://downloads.yoctoproject.org/releases/eglibc/eglibc-${PV}-svnr21224.tar.bz2;name=tarball \
            file://eglibc-svn-arm-lowlevellock-include-tls.patch \
            file://IO-acquire-lock-fix.patch \
            file://mips-rld-map-check.patch \
@@ -27,15 +27,24 @@ SRC_URI = "http://downloads.yoctoproject.org/releases/eglibc/eglibc-${PV}-svnr21
            file://0001-Add-name_to_handle_at-open_by_handle-etc.-to-PowerPC.patch \
            file://fsl-ppc-no-fsqrt.patch \
            file://0001-R_ARM_TLS_DTPOFF32.patch \
-           http://people.linaro.org/~toolchain/openembedded/patches/eglibc/aarch64-0001-glibc-fsf-v1-eaf6f205.patch \
-           http://people.linaro.org/~toolchain/openembedded/patches/eglibc/aarch64-0002-Synchronize-with-linux-elf.h.patch \
-           http://people.linaro.org/~toolchain/openembedded/patches/eglibc/aarch64-0003-Adding-AArch64-support-to-elf-elf.h.patch \
+           http://people.linaro.org/~toolchain/openembedded/patches/eglibc/aarch64-0001-glibc-fsf-v1-eaf6f205.patch;name=patch1 \
+           http://people.linaro.org/~toolchain/openembedded/patches/eglibc/aarch64-0002-Synchronize-with-linux-elf.h.patch;name=patch2 \
+           http://people.linaro.org/~toolchain/openembedded/patches/eglibc/aarch64-0003-Adding-AArch64-support-to-elf-elf.h.patch;name=patch3 \
            file://tzselect-sh.patch \
            file://tzselect-awk.patch \
           "
 
-SRC_URI[md5sum] = "88894fa6e10e58e85fbd8134b8e486a8"
-SRC_URI[sha256sum] = "460a45f422da6eb1fd909baab6a64b5ae4c8ba18ea05a1491ed1024c8b98eeaa"
+SRC_URI[tarball.md5sum] = "88894fa6e10e58e85fbd8134b8e486a8"
+SRC_URI[tarball.sha256sum] = "460a45f422da6eb1fd909baab6a64b5ae4c8ba18ea05a1491ed1024c8b98eeaa"
+
+SRC_URI[patch1.md5sum] = "5e52bf8fd9ac390b665d86a57ab7dba7"
+SRC_URI[patch1.sha256sum] = "b7eea76e72675a6ed3066952a9e08389c99838d74a58b736d527c82c34e754eb"
+
+SRC_URI[patch2.md5sum] = "e1ae1c416c01e2c991c7ca7e169c577b"
+SRC_URI[patch2.sha256sum] = "6093bb80a187081090cb14412f466c08fcaf39ccd62b751e3d871a8c5af03b0d"
+
+SRC_URI[patch3.md5sum] = "6d1d84e14f7abfe9ee3237d0ec6fe9ca"
+SRC_URI[patch3.sha256sum] = "03e79ace9eade0d57a3684cb0dc6b415ea52e4f152bfb380684b08445f125410"
 
 LIC_FILES_CHKSUM = "file://LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9 \
       file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \