]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemtap: add build dependency on ncurses
authorRoss Burton <ross.burton@intel.com>
Fri, 10 Jun 2016 16:55:12 +0000 (17:55 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 12 Jun 2016 22:47:00 +0000 (23:47 +0100)
systemtap has a floating dependency on ncurses but as bash is a RDEPENDS the
build-rdeps sanity test doesn't fire due to a limitation of the test.

Add an explicit dependency on ncurses to ensure the build is deterministic.

[ YOCTO #9709 ]

Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-kernel/systemtap/systemtap_git.bb

index a4bda6930e6ca36b46fc58620e03501932741369..da30fa5e6da94978080285b4964f09565ed948e0 100644 (file)
@@ -2,7 +2,7 @@ SUMMARY = "Script-directed dynamic tracing and performance analysis tool for Lin
 
 require systemtap_git.inc
 
-DEPENDS = "elfutils sqlite3 systemtap-native json-c"
+DEPENDS = "elfutils sqlite3 systemtap-native ncurses json-c"
 DEPENDS_class-native = "elfutils-native sqlite3-native gettext-native"
 DEPENDS_class-nativesdk = "nativesdk-elfutils nativesdk-sqlite3 nativesdk-gettext"