]> code.ossystems Code Review - openembedded-core.git/commitdiff
packages/modutils/modutils-collateral.bb: Modprobe has changed between 2.4 and 2...
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 26 Oct 2007 11:25:09 +0000 (11:25 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 26 Oct 2007 11:25:09 +0000 (11:25 +0000)
The information in /etc/modutils and /etc/modules.conf is not read under 2.6.
2.6 uses a /etc/modprobe.d directory, and it does not need a
"/etc/modprobe.conf" file; it reads all the appropriate *.conf files and
compiles the information at boot time.
This commit closes bug #808

git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2993 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/modutils/modutils-collateral.bb

index 5c502021f95862fece5957adab72c2a6bcd629eb..6d010a575440d1fd343f209ac453a76ac39c7d9f 100644 (file)
@@ -1,6 +1,6 @@
 SECTION = "base"
 DESCRIPTION = "modutils configuration files"
-PR = "r2"
+PR = "r3"
 LICENSE = "MIT"
 
 SRC_URI = "file://modules \
@@ -12,5 +12,10 @@ do_compile () {
 do_install () {
        install -d ${D}${sysconfdir}
        install -m 0644 ${WORKDIR}/modules ${D}${sysconfdir}/modules
-       install -m 0644 ${WORKDIR}/modules.conf ${D}${sysconfdir}/modules.conf
+        if [ ${MAJOR_KERNEL_VERSION}=2.6 ]; then
+        install -d ${D}${sysconfdir}/modprobe.d         
+        else
+        install -m 0644 ${WORKDIR}/modules.conf ${D}${sysconfdir}/modules.conf
+        fi
+
 }