]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add mc to openembedded-extras
authorRichard Purdie <richard@openedhand.com>
Fri, 26 May 2006 13:47:41 +0000 (13:47 +0000)
committerRichard Purdie <richard@openedhand.com>
Fri, 26 May 2006 13:47:41 +0000 (13:47 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@431 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded-extras/packages/mc/mc_4.6.0.bb [new file with mode: 0644]

diff --git a/openembedded-extras/packages/mc/mc_4.6.0.bb b/openembedded-extras/packages/mc/mc_4.6.0.bb
new file mode 100644 (file)
index 0000000..6636c67
--- /dev/null
@@ -0,0 +1,32 @@
+DESCRIPTION = "GNU Midnight Commander is a file \
+manager for free operating systems."
+HOMEPAGE = "http://www.ibiblio.org/mc/"
+LICENSE = "GPLv2"
+SECTION = "console/utils"
+PRIORITY = "optional"
+DEPENDS = "ncurses glib-2.0"
+RDEPENDS = "ncurses-terminfo"
+
+SRC_URI = "http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/mc-${PV}.tar.gz"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-glibtest --without-x --without-samba \
+--without-nfs --without-gpm-mouse"
+
+do_configure() {
+       gnu-configize
+       oe_runconf
+}
+
+do_install() {
+       cd src
+       oe_runmake 'DESTDIR=${D}' install
+       cd ../syntax
+       oe_runmake 'DESTDIR=${D}' install
+       cd ../po
+       oe_runmake 'DESTDIR=${D}' install
+       cd ../vfs
+       oe_runmake 'DESTDIR=${D}' install
+       cd ..
+}