]> code.ossystems Code Review - openembedded-core.git/commitdiff
base-files: avoid overwritting editable files during package updating
authorJian Liu <jian.liu@windriver.com>
Fri, 21 Nov 2014 09:17:10 +0000 (17:17 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 3 Dec 2014 12:22:41 +0000 (12:22 +0000)
Use CONFFILES to mark editable files as such,
  /etc/motd
  /etc/nsswitch.conf
  /etc/profile

If there is no %config micro before the file name in the spec file,
this file will be overwritten after updating package.
This will make our settings lost.

Signed-off-by: Jian Liu <jian.liu@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/base-files/base-files_3.0.14.bb

index 07f5c54c97d86ef716b40c0662d466d897ca9611..6157ff381a0316a3f231ca1f288a2807f3e17560 100644 (file)
@@ -151,4 +151,5 @@ FILES_${PN}-doc = "${docdir} ${datadir}/common-licenses"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 CONFFILES_${PN} = "${sysconfdir}/fstab ${@['', '${sysconfdir}/hostname'][(d.getVar('hostname', True) != '')]} ${sysconfdir}/shells"
+CONFFILES_${PN} += "${sysconfdir}/motd ${sysconfdir}/nsswitch.conf ${sysconfdir}/profile"