]> code.ossystems Code Review - openembedded-core.git/commitdiff
tcl: fix tclConfig.sh to point to the correct private headers
authorSaul Wold <sgw@linux.intel.com>
Thu, 5 Dec 2013 16:26:20 +0000 (08:26 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 5 Dec 2013 16:48:17 +0000 (16:48 +0000)
When building expect with rm_work enabled, it was not finding the correct private
header files because they were removed from the WORKDIR, this fixes the tclConfig.sh
to point to the sysroot private area instead.

This also fixes the -L directory to point to STAGING_LIBDIR instead if INCDIR!

[YOCTO #5620]

Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/tcltk/tcl_8.6.1.bb

index 10186c43d61a5beaa4f9cec16ee1af5050f86c91..0d6468a38cd57ca41b85f5ba7e87d05bde9315bf 100644 (file)
@@ -48,11 +48,13 @@ do_compile_prepend() {
 do_install() {
        autotools_do_install install-private-headers
        ln -sf ./tclsh${VER} ${D}${bindir}/tclsh
+       sed -i "s+-L${B}+-L${STAGING_LIBDIR}+g" tclConfig.sh
        sed -i "s+${WORKDIR}+${STAGING_INCDIR}+g" tclConfig.sh
        sed -i "s,-L${libdir},-L=${libdir},g" tclConfig.sh
        sed -i "s,-I${includedir},-I=${includedir},g" tclConfig.sh 
        install -d ${D}${bindir_crossscripts}
        install -m 0755 tclConfig.sh ${D}${bindir_crossscripts}
+       install -m 0755 tclConfig.sh ${D}${libdir}
        cd ..
        for dir in compat generic unix
        do