]> code.ossystems Code Review - openembedded-core.git/commitdiff
xcb-proto: create .pyc files for python2
authorRobert Yang <liezhi.yang@windriver.com>
Thu, 22 Sep 2016 09:36:55 +0000 (02:36 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 15 Oct 2016 08:54:24 +0000 (09:54 +0100)
Its Makefile's do_install creates .pyc files for python3, now also
create them for python2 so that they will be recorded by manifest, and
can be cleaned correctly.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb

index 8bdca32b71c269cb3afe4efd7734f39f3456c2b0..7d4a6b4364125f4836e1149d4a3dfe69e5cfc110 100644 (file)
@@ -28,3 +28,10 @@ RDEPENDS_${PN}-dev = ""
 RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"
 
 BBCLASSEXTEND = "native nativesdk"
+
+do_install_append() {
+    # Makefile's do_install creates .pyc files for python3, now also create
+    # them for python2 so that they will be recorded by manifest, and can be
+    # cleaned correctly.
+    python -m py_compile ${D}${libdir}/xcb-proto/xcbgen/*.py
+}