]> code.ossystems Code Review - openembedded-core.git/commitdiff
musl: Update to latest master
authorKhem Raj <raj.khem@gmail.com>
Tue, 27 Oct 2020 17:58:37 +0000 (10:58 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 30 Oct 2020 12:37:53 +0000 (12:37 +0000)
Changes in this revision bump are
0b87551b (upstream/master) lift sigaction abort locking to fix posix_spawn child deadlock
99d5098a update crypt_blowfish to support $2b$ prefix
957c2763 remove unused weak definition of __tl_sync in membarrier.c
55767360 move aio implementation details to a proper internal header
37337660 remove long-unused struct __timer from pthread_impl.h
85e16aec drop use of pthread_once in timer_create
6ae2568b remove unused SIGTIMER handler in timer_create
47baa030 remove incorrect fflush from assert failure handler
da845d52 fix getgrouplist when nscd reports an empty list
b7bc9665 fix posix_spawn interaction with fork and abort by taking lock
25ea9f71 fix unintended observability of SIGABRT disposition reset via sigaction
bd153422 implement _Fork and refactor fork using it
e1e98d86 rename fork source file
50716702 ldso: use pthread_t rather than kernel tid to track ctor visitor
1efc8eb2 fix stale lock when allocation of ctor queue fails during dlopen
69a1b390 drop use of pthread_once in mutexattr kernel support tests
b115bee4 fix missing synchronization of fork with abort
3cd3de61 move __abort_lock to its own file and drop pointless weak_alias trick
34904d83 fix fork of processes with active async io contexts

Details are here [1]

[1] https://git.musl-libc.org/cgit/musl/log/?qt=range&q=a5aff1972c9e3981566414b09a28e331ccd2be5d..0b87551bdfb74ac411caa335d8ad0b89a7f139c6

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/musl/musl_git.bb

index 9c0818cfa5934b1dd0b10583af8a8fb57176d661..897e56e10fb9ffc48027f79637d8b6d2fc732cc2 100644 (file)
@@ -4,7 +4,7 @@
 require musl.inc
 inherit linuxloader
 
-SRCREV = "a5aff1972c9e3981566414b09a28e331ccd2be5d"
+SRCREV = "0b87551bdfb74ac411caa335d8ad0b89a7f139c6"
 
 BASEVER = "1.2.1"