]> code.ossystems Code Review - openembedded-core.git/commitdiff
consolekit: fix console-kit-log-system-start.service startup
authorJonathan Liu <net147@gmail.com>
Tue, 27 May 2014 02:15:14 +0000 (22:15 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 24 Jun 2014 10:05:26 +0000 (11:05 +0100)
console-kit-log-system-start.service fails to to start if the
/var/log/ConsoleKit directory does not exist. Normally it is created
automatically but as we mount a tmpfs at /var/log, we need to add
a tmpfiles.d entry to create it.

(From OE-Core master rev: 2a9a14bf400fe0c263c58aa85b02aba7311b1328)

Signed-off-by: Jonathan Liu <net147@gmail.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
meta/recipes-support/consolekit/consolekit_0.4.6.bb

index 63da028f818f4cc68fa4e9da2dde86c0c9919b05..ac5c37fd39212a4f30ee40a358cf95113cd4bb10 100644 (file)
@@ -37,6 +37,12 @@ FILES_pam-plugin-ck-connector += "${base_libdir}/security/*.so"
 RDEPENDS_pam-plugin-ck-connector += "${PN}"
 
 do_install_append() {
+       if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+               install -d ${D}${sysconfdir}/tmpfiles.d
+               echo "d ${localstatedir}/log/ConsoleKit - - - -" \
+                       > ${D}${sysconfdir}/tmpfiles.d/consolekit.conf
+       fi
+
        # Remove /var/run from package as console-kit-daemon will populate it on startup
        rm -fr "${D}${localstatedir}/run"
 }