]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-libc-headers: Remove ioctls for deleted driver
authorDike, Jeffrey G <jeffrey.g.dike@intel.com>
Wed, 16 Jun 2010 21:32:49 +0000 (14:32 -0700)
committerJoshua Lock <josh@linux.intel.com>
Thu, 17 Jun 2010 11:33:10 +0000 (12:33 +0100)
2.6.33 removed the Hayes ESP driver.  The presence of these ioctls
makes setserial believe that ESP support should be built in, breaking its
build.

Signed-off-by: Jeff Dike <jdike@linux.intel.com>
meta/packages/linux-libc-headers/linux-libc-headers-2.6.33/hayes-gone.patch [new file with mode: 0644]
meta/packages/linux-libc-headers/linux-libc-headers_2.6.33.bb

diff --git a/meta/packages/linux-libc-headers/linux-libc-headers-2.6.33/hayes-gone.patch b/meta/packages/linux-libc-headers/linux-libc-headers-2.6.33/hayes-gone.patch
new file mode 100644 (file)
index 0000000..dc6338a
--- /dev/null
@@ -0,0 +1,25 @@
+# 2.6.33 deleted the Hayes esp driver, so the ioctls to get and set its
+# configuration are no longer needed, and they break setserial by making it
+# believe that it should compile in the code that supports this modem.
+
+Index: linux-2.6.33/include/asm-generic/ioctls.h
+===================================================================
+--- linux-2.6.33.orig/include/asm-generic/ioctls.h
++++ linux-2.6.33/include/asm-generic/ioctls.h
+@@ -86,16 +86,6 @@
+ #define TIOCMIWAIT    0x545C  /* wait for a change on serial input line(s) */
+ #define TIOCGICOUNT   0x545D  /* read serial port inline interrupt counts */
+-/*
+- * some architectures define FIOQSIZE as 0x545E, which is used for
+- * TIOCGHAYESESP on others
+- */
+-#ifndef FIOQSIZE
+-# define TIOCGHAYESESP        0x545E  /* Get Hayes ESP configuration */
+-# define TIOCSHAYESESP        0x545F  /* Set Hayes ESP configuration */
+-# define FIOQSIZE     0x5460
+-#endif
+-
+ /* Used for packet mode */
+ #define TIOCPKT_DATA           0
+ #define TIOCPKT_FLUSHREAD      1
index e706988070137d2841bbdbadb3c5bd0ff4649567..4a63910e826b515c48333a3db3d4b2856b4e3313 100644 (file)
@@ -2,9 +2,10 @@ require linux-libc-headers.inc
 
 INHIBIT_DEFAULT_DEPS = "1"
 DEPENDS += "unifdef-native"
-PR = "r0"
+PR = "r1"
 
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2"
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+       file://hayes-gone.patch"
 
 S = "${WORKDIR}/linux-${PV}"