]> code.ossystems Code Review - openembedded-core.git/commitdiff
blktrace: Fix parallel make issue
authorTom Zanussi <tom.zanussi@intel.com>
Wed, 29 Dec 2010 17:25:42 +0000 (11:25 -0600)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 30 Dec 2010 09:37:39 +0000 (09:37 +0000)
Fixes [BUGID #581]

When PARALLEL_MAKE is used with the current blktrace Makefile, the
btreplay and btrecord object files can end up being built multiple
times in parallel, which occasionally causes the linker to pick up the
object files in intermediate and seemingly corrupt states, and causes
the spurious link errors in the bug report.

This fix restricts the recursive btreplay invocations to building only
btreplay or btrecord as appropriate, not both.

Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
meta/recipes-kernel/blktrace/blktrace/blktrace-makefile.patch
meta/recipes-kernel/blktrace/blktrace_git.bb

index 87ee24ea35d134ec8ba5e70db37d21a4bf0d5854..c6a06ed34945facdc637459d3ff381ddc9744bf5 100644 (file)
@@ -17,11 +17,11 @@ Index: git/Makefile
  
  btreplay/btrecord:
 -      $(MAKE) -C btreplay
-+      CC="${CC}" CFLAGS="${CFLAGS}" $(MAKE) -C btreplay CC="${CC}" CFLAGS="${CFLAGS}"
++      CC="${CC}" CFLAGS="${CFLAGS}" $(MAKE) -C btreplay CC="${CC}" CFLAGS="${CFLAGS}" btrecord
  
  btreplay/btreplay:
 -      $(MAKE) -C btreplay
-+      CC="${CC}" CFLAGS="${CFLAGS}" $(MAKE) -C btreplay CC="${CC}" CFLAGS="${CFLAGS}"
++      CC="${CC}" CFLAGS="${CFLAGS}" $(MAKE) -C btreplay CC="${CC}" CFLAGS="${CFLAGS}" btreplay
  
  %.o: %.c
        $(CC) -o $*.o -c $(ALL_CFLAGS) $<
index 5690f1463baefe5808e550fcd666bc8bc2a42b68..85e4a4b3cebf13c907263251514bde6783b1403a 100644 (file)
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
 
 DEPENDS = "libaio"
 
-PR = r0
+PR = r1
 PV = "1.0.1+git${SRCPV}"
 
 SRC_URI = "git://git.kernel.dk/blktrace.git;protocol=git \