]> code.ossystems Code Review - openembedded-core.git/commitdiff
opkg-utils: Print out License field
authorKhem Raj <raj.khem@gmail.com>
Thu, 14 Jul 2011 06:31:20 +0000 (23:31 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 14 Jul 2011 13:55:06 +0000 (14:55 +0100)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/opkg-utils/opkg-utils/add-license-field.patch [new file with mode: 0644]
meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb

diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils/add-license-field.patch b/meta/recipes-devtools/opkg-utils/opkg-utils/add-license-field.patch
new file mode 100644 (file)
index 0000000..0d33459
--- /dev/null
@@ -0,0 +1,39 @@
+Add knowledge about License field in ipk headers
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Index: opkg-utils/opkg.py
+===================================================================
+--- opkg-utils.orig/opkg.py    2010-11-01 04:52:35.000000000 -0700
++++ opkg-utils/opkg.py 2011-07-13 15:18:03.900037344 -0700
+@@ -145,6 +145,7 @@
+         self.priority = None
+         self.tags = None
+         self.fn = fn
++        self.license = None
+         if fn:
+             # see if it is deb format
+@@ -319,6 +320,12 @@
+     def get_section(self, section):
+         return self.section
++    def set_license(self, license):
++        self.license = license
++
++    def get_license(self, license):
++        return self.license
++
+     def get_file_list(self):
+         if not self.fn:
+             return []
+@@ -425,6 +432,7 @@
+         if self.description: out = out + "Description: %s\n" % (self.description)
+         if self.oe: out = out + "OE: %s\n" % (self.oe)
+         if self.homepage: out = out + "HomePage: %s\n" % (self.homepage)
++        if self.license: out = out + "License: %s\n" % (self.license)
+         if self.priority: out = out + "Priority: %s\n" % (self.priority)
+         if self.tags: out = out + "Tags: %s\n" % (self.tags)
+         out = out + "\n"
index 897fe113d242ba1b8d4815c120d19bb6cfa4f8fd..fd2b5e693dc99b8ecc79a36f8cdbb5128ebbe7e4 100644 (file)
@@ -8,11 +8,12 @@ RDEPENDS_${PN} = "python"
 RDEPENDS_${PN}_virtclass-native = ""
 SRCREV = "4747"
 PV = "0.1.8+svnr${SRCPV}"
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=opkg-utils;proto=http \
            file://index-ignore-filenotfound.patch \
            file://mtime-int.patch \
+           file://add-license-field.patch \
            "
 
 S = "${WORKDIR}/opkg-utils"