]> code.ossystems Code Review - openembedded-core.git/commitdiff
logrotate: fix recompile error
authorRobert Yang <liezhi.yang@windriver.com>
Thu, 7 Aug 2014 03:05:22 +0000 (20:05 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 11 Aug 2014 09:46:58 +0000 (10:46 +0100)
Fixed:
NOTE: make -j 32
make: *** No rule to make target `/path/to/sysroot/4.9.0/include/stddef.h', needed by `logrotate.o'.  Stop.

This happens when upgrade gcc from 4.9.0 to 4.9.1, and the .depend isn't
regenerated when recompile, the content of the .depend are:

[snip]
logrotate.o: /path/to/sysroot/4.9.0/include/stddef.h
[snip]

And Makefile includes the .depend file if it exists, so there would be
errors when /path/to/sysroot/4.9.0/include/stddef.h doesn't exist.

Remove .depend will fix the problem.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/logrotate/logrotate_3.8.7.bb

index b386b85bf60713320d32e69bb970636eb0657cb8..3a6a2287dbd02d334bb12a15387e605ace9006e9 100644 (file)
@@ -18,6 +18,11 @@ SRC_URI[sha256sum] = "f6ba691f40e30e640efa2752c1f9499a3f9738257660994de70a45fe00
 
 EXTRA_OEMAKE = ""
 
+do_compile_prepend() {
+    # Make sure the recompile is OK
+    rm -f ${B}/.depend
+}
+
 do_install(){
     oe_runmake install DESTDIR=${D} PREFIX=${D} MANDIR=${mandir}
     mkdir -p ${D}${sysconfdir}/logrotate.d