]> code.ossystems Code Review - openembedded-core.git/commitdiff
cwautomacros: Ensure version is set deterministically
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 14 Feb 2021 12:05:10 +0000 (12:05 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 16 Feb 2021 11:28:01 +0000 (11:28 +0000)
The makefile injects the current date into the version file. Do this
deterministically with SOURCE_DATE_EPOCH.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/cwautomacros/cwautomacros_20110201.bb

index 65a99fc28d71fa4d3b36cf26ab4e377efce73731..02b016fdf1f37e7919a9cf3bb4a31f65788b1dad 100644 (file)
@@ -13,7 +13,7 @@ do_configure() {
 }
 
 do_install() {
-       oe_runmake CWAUTOMACROSPREFIX=${D}${prefix} install
+       oe_runmake LABEL=`date -d @${SOURCE_DATE_EPOCH} +%Y%m%d` CWAUTOMACROSPREFIX=${D}${prefix} install
 
        # cleanup buildpaths in autogen.sh
        sed -i -e 's,${D},,g' ${D}${prefix}/share/cwautomacros/scripts/autogen.sh