]> code.ossystems Code Review - openembedded-core.git/commitdiff
hal: split libraries to separate packages
authorMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 30 Jan 2008 22:04:03 +0000 (22:04 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 30 Jan 2008 22:04:03 +0000 (22:04 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3644 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/hal/hal_0.5.9.1.bb

index 9cfc28a03df69a35c04ee161207ea1b54018e186..8422647ac4f99e16ddf7cf69ad257b1692ca8bff 100644 (file)
@@ -7,7 +7,7 @@ DEPENDS = "virtual/kernel dbus-glib udev intltool-native expat libusb"
 RDEPENDS_${PN} += "udev hal-info"
 RRECOMMENDS_${PN} += "udev-utils"
 
-PR = "r4"
+PR = "r5"
 
 SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz \
         file://sg-inhibit.patch;patch=1 \
@@ -46,7 +46,7 @@ do_stage() {
 
 # At the time the postinst runs, dbus might not be setup so only restart if running
 pkg_postinst_hal () {
-       # can't do this offline
+       # can not do this offline
        if [ "x$D" != "x" ]; then
                exit 1
        fi
@@ -68,6 +68,11 @@ pkg_postrm_hal () {
        delgroup haldaemon || true
 }
 
+PACKAGES =+ "libhal libhal-storage"
+
+FILES_libhal = "${libdir}/libhal.so.*"
+FILES_libhal-storage = "${libdir}/libhal-storage.so.*"
+
 FILES_${PN} = "${sysconfdir} \
                 ${bindir}/lshal \
                 ${bindir}/hal-find-by-capability \