]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxml-sax-base-perl: add recipe for libxml-sax-perl
authorXin Ouyang <Xin.Ouyang@windriver.com>
Fri, 30 Nov 2012 10:29:59 +0000 (18:29 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 3 Dec 2012 15:22:34 +0000 (15:22 +0000)
If libxml-sax-base-perl is not installed on the target, libxml-sax-perl
would be fail to use. So add the recipe.

    # cat > test.pl <<-EOF
    #!/usr/bin/perl
    use XML::SAX;
    EOF
    # perl ./test.pl
    Can't locate XML/SAX/Exception.pm in @INC ...

Also inherit allarch for three perl modules.

Signed-off-by: Xin Ouyang <Xin.Ouyang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/perl/libxml-namespacesupport-perl_1.11.bb
meta/recipes-extended/perl/libxml-sax-base-perl_1.08.bb [new file with mode: 0644]
meta/recipes-extended/perl/libxml-sax-perl_0.99.bb

index cf89cb695205a24ba212f567d4807b3ff0422fb7..928440377cece39d6b08c9bdef6e51ae3c5e3d9a 100644 (file)
@@ -5,7 +5,7 @@ DESCRIPTION = "XML::NamespaceSupport offers a simple way to process namespace-ba
 
 SECTION = "libs"
 LICENSE = "Artistic-1.0 | GPL-1.0+"
-PR = "r2"
+PR = "r3"
 
 LIC_FILES_CHKSUM = "file://META.yml;beginline=22;endline=22;md5=3b2b564dae8b9af9e8896e85c07dcbe5"
 
@@ -16,7 +16,7 @@ SRC_URI[sha256sum] = "6d8151f0a3f102313d76b64bfd1c2d9ed46bfe63a16f038e7d860fda28
 
 S = "${WORKDIR}/XML-NamespaceSupport-${PV}"
 
-inherit cpan
+inherit cpan allarch
 
 BBCLASSEXTEND="native"
 
diff --git a/meta/recipes-extended/perl/libxml-sax-base-perl_1.08.bb b/meta/recipes-extended/perl/libxml-sax-base-perl_1.08.bb
new file mode 100644 (file)
index 0000000..d87c044
--- /dev/null
@@ -0,0 +1,24 @@
+SUMMARY = "Base class SAX Drivers and Filters"
+DESCRIPTION = "This module has a very simple task - to be a base class for \
+PerlSAX drivers and filters. It's default behaviour is to pass \
+the input directly to the output unchanged. It can be useful to \
+use this module as a base class so you don't have to, for example, \
+implement the characters() callback."
+
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+RDEPENDS += "perl-module-extutils-makemaker"
+PR = "r0"
+
+LIC_FILES_CHKSUM = "file://dist.ini;endline=5;md5=8f9c9a55340aefaee6e9704c88466446"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GR/GRANTM/XML-SAX-Base-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "38c8c3247dfd080712596118d70dbe32"
+SRC_URI[sha256sum] = "666270318b15f88b8427e585198abbc19bc2e6ccb36dc4c0a4f2d9807330219e"
+
+S = "${WORKDIR}/XML-SAX-Base-${PV}"
+
+inherit cpan allarch
+
+BBCLASSEXTEND = "native"
index 3a0873fe418efde3d27c94d43b47c916367092d9..647cb77fa844ebd23b063956a519ad774fcf6d75 100644 (file)
@@ -10,8 +10,8 @@ javaness."
 SECTION = "libs"
 LICENSE = "Artistic-1.0 | GPL-1.0+"
 DEPENDS += "libxml-namespacesupport-perl-native"
-RDEPENDS_${PN} += "libxml-namespacesupport-perl perl-module-file-temp"
-PR = "r1"
+RDEPENDS_${PN} += "libxml-namespacesupport-perl libxml-sax-base-perl perl-module-file-temp"
+PR = "r2"
 
 LIC_FILES_CHKSUM = "file://LICENSE;md5=65c4cd8f39c24c7135ed70dacbcb09e3"
 
@@ -22,6 +22,6 @@ SRC_URI[sha256sum] = "32b04b8e36b6cc4cfc486de2d859d87af5386dd930f2383c49347050d6
 
 S = "${WORKDIR}/XML-SAX-${PV}"
 
-inherit cpan
+inherit cpan allarch
 
 BBCLASSEXTEND = "native"