]> code.ossystems Code Review - openembedded-core.git/commitdiff
apr-util: make gdbm optional
authorAlexander Kanavin <alex.kanavin@gmail.com>
Wed, 17 Jun 2020 10:15:51 +0000 (12:15 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 17 Jun 2020 15:31:48 +0000 (16:31 +0100)
This helps with gpl3-free builds.

Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/apr/apr-util_1.6.1.bb

index 3896c924f01478dc0f4c500eecfab42e94c5c91d..0dd8f025e835c6b657a62bb93a81f045dbd2d55a 100644 (file)
@@ -1,7 +1,7 @@
 SUMMARY = "Apache Portable Runtime (APR) companion library"
 HOMEPAGE = "http://apr.apache.org/"
 SECTION = "libs"
-DEPENDS = "apr expat gdbm"
+DEPENDS = "apr expat"
 
 BBCLASSEXTEND = "native nativesdk"
 
@@ -23,7 +23,6 @@ EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \
                --without-odbc \
                --without-pgsql \
                --with-dbm=gdbm \
-               --with-gdbm=${STAGING_DIR_HOST}${prefix} \
                --without-sqlite2 \
                --with-expat=${STAGING_DIR_HOST}${prefix}"
 
@@ -66,10 +65,11 @@ do_install_append_class-target() {
               -e 's,APU_BUILD_DIR=.*,APR_BUILD_DIR=,g' ${D}${bindir}/apu-1-config
 }
 
-PACKAGECONFIG ??= "crypto"
+PACKAGECONFIG ??= "crypto gdbm"
 PACKAGECONFIG[ldap] = "--with-ldap,--without-ldap,openldap"
 PACKAGECONFIG[crypto] = "--with-openssl=${STAGING_DIR_HOST}${prefix} --with-crypto,--without-crypto,openssl"
 PACKAGECONFIG[sqlite3] = "--with-sqlite3=${STAGING_DIR_HOST}${prefix},--without-sqlite3,sqlite3"
+PACKAGECONFIG[gdbm] = "--with-gdbm=${STAGING_DIR_HOST}${prefix},--without-gdbm,gdbm"
 
 #files ${libdir}/apr-util-1/*.so are not symlinks but loadable modules thus they are packaged in ${PN}
 FILES_${PN}     += "${libdir}/apr-util-1/apr*${SOLIBS} ${libdir}/apr-util-1/apr*${SOLIBSDEV}"