]> code.ossystems Code Review - openembedded-core.git/commitdiff
ghostscript: Really fix parallel make race
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 25 Nov 2011 13:10:41 +0000 (13:10 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 26 Nov 2011 22:41:01 +0000 (22:41 +0000)
There continue to be parallel make race issues showing up on the autobuilder.
This patch removes some potential sources of these. The rm is unrequired
since we're using cp -f. The || true ensures that if we did race against
someone it becomes harmless.

[YOCTO #1202]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/ghostscript/ghostscript/ghostscript-9.02-parallel-make.patch
meta/recipes-extended/ghostscript/ghostscript_9.04.bb

index 76d167650dde40c1c7bcc818e6e07830a0c2fc62..bb0c41c40c66511dd1ceddb6a5d3af223a6877c0 100644 (file)
@@ -4,6 +4,8 @@ http://bugzilla.pokylinux.org/show_bug.cgi?id=1202
 Upstream-Status: Pending
 
 Signed-off-by: Kang Kai <kai.kang@windriver.com>
+
+RP: Tweaked to include lib.mak fixes
 --- ghostscript-9.02/base/unixhead.mak.orig    2011-07-27 17:06:17.749456100 +0800
 +++ ghostscript-9.02/base/unixhead.mak 2011-07-27 17:06:37.449456100 +0800
 @@ -54,7 +54,7 @@
@@ -15,3 +17,20 @@ Signed-off-by: Kang Kai <kai.kang@windriver.com>
  RM_=rm -f
  RMN_=rm -f
  
+Index: ghostscript-9.04/base/lib.mak
+===================================================================
+--- ghostscript-9.04.orig/base/lib.mak 2011-11-25 13:06:21.728502636 +0000
++++ ghostscript-9.04/base/lib.mak      2011-11-25 13:08:33.924504957 +0000
+@@ -592,10 +592,8 @@
+  $(gscdefs_h) $(gconf_h)\
+  $(gxdevice_h) $(gxiclass_h) $(gxiodev_h) $(gxiparam_h) $(TOP_MAKEFILES)\
+  $(MAKEDDIRS)
+-      $(RM_) $(GLGEN)gconfig.c
+-      $(RM_) $(GLGEN)gconfig.h
+-      $(CP_) $(gconfig_h) $(GLGEN)gconfig.h
+-      $(CP_) $(GLSRC)gconf.c $(GLGEN)gconfig.c
++      $(CP_) $(gconfig_h) $(GLGEN)gconfig.h || true
++      $(CP_) $(GLSRC)gconf.c $(GLGEN)gconfig.c || true
+       $(GLCC) $(GLO_)gconfig.$(OBJ) $(C_) $(GLGEN)gconfig.c
+ $(GLOBJ)gscdefs.$(OBJ) : $(GLSRC)gscdef.c\
index dba92e9abad2f9c12f07170c6410c9a580ca555a..d4448109bbba1f4eabdd361fe1ad96cc737c5709 100644 (file)
@@ -15,7 +15,7 @@ SECTION = "console/utils"
 LICENSE = "GPLv3"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=d151214b3131251dfc9d858593acbd24"
 
-PR = "r0"
+PR = "r1"
 
 DEPENDS = "ghostscript-native tiff jpeg fontconfig cups"
 DEPENDS_virtclass-native = ""