]> code.ossystems Code Review - openembedded-core.git/commitdiff
wireless-tools: Remove QA warning: No GNU_HASH in the elf binary
authorMuhammad Shakeel <muhammad_shakeel@mentor.com>
Wed, 19 Dec 2012 06:35:53 +0000 (11:35 +0500)
committerSaul Wold <sgw@linux.intel.com>
Tue, 25 Dec 2012 22:00:20 +0000 (14:00 -0800)
Handle LDFLAGS properly in the Makefile to remove warning:
QA Issue: No GNU_HASH in the elf binary

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Signed-off-by: Muhammad Shakeel <muhammad_shakeel@mentor.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-connectivity/wireless-tools/wireless-tools/ldflags.patch [new file with mode: 0644]
meta/recipes-connectivity/wireless-tools/wireless-tools_29.bb

diff --git a/meta/recipes-connectivity/wireless-tools/wireless-tools/ldflags.patch b/meta/recipes-connectivity/wireless-tools/wireless-tools/ldflags.patch
new file mode 100644 (file)
index 0000000..6c0d8cb
--- /dev/null
@@ -0,0 +1,22 @@
+wireless-tools: Remove QA warning: No GNU_HASH in the elf binary
+
+Upstream-Status: Inappropriate [other]
+  Useful within bitbake environment only.
+
+Signed-off-by: Muhammad Shakeel <muhammad_shakeel@mentor.com>
+
+---
+ Makefile |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- wireless_tools.29.orig/Makefile
++++ wireless_tools.29/Makefile
+@@ -144,7 +144,7 @@ wireless.h:
+ # Compilation of the dynamic library
+ $(DYNAMIC): $(OBJS:.o=.so)
+-      $(CC) -shared -o $@ -Wl,-soname,$@ $(STRIPFLAGS) $(LIBS) -lc $^
++      $(CC) -shared -o $@ -Wl,-soname,$@ $(LDFLAGS) $(STRIPFLAGS) $(LIBS) -lc $^
+ # Compilation of the static library
+ $(STATIC): $(OBJS:.o=.so)
index 209f29ae2c82a8e0720fe6d0c983ceedcd5085a7..b4d34bb47c2d9cdbd5bcc0c0332d5cba02a7bf88 100644 (file)
@@ -14,7 +14,8 @@ SRC_URI = "http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/wireless_tools.2
           file://man.patch \
           file://wireless-tools.if-pre-up \
           file://zzz-wireless.if-pre-up \
-          file://avoid_strip.patch"
+          file://avoid_strip.patch \
+          file://ldflags.patch"
 
 SRC_URI[md5sum] = "e06c222e186f7cc013fd272d023710cb"
 SRC_URI[sha256sum] = "6fb80935fe208538131ce2c4178221bab1078a1656306bce8909c19887e2e5a1"