]> code.ossystems Code Review - openembedded-core.git/commitdiff
alsa-lib: sync with OE (fpu settings)
authorMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 25 Oct 2007 11:23:56 +0000 (11:23 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 25 Oct 2007 11:23:56 +0000 (11:23 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2957 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/alsa/alsa-fpu.inc [new file with mode: 0644]
meta/packages/alsa/alsa-lib_1.0.14.bb

diff --git a/meta/packages/alsa/alsa-fpu.inc b/meta/packages/alsa/alsa-fpu.inc
new file mode 100644 (file)
index 0000000..ebd3493
--- /dev/null
@@ -0,0 +1,6 @@
+
+def get_alsa_fpu_setting(bb, d):
+       if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
+               return "--with-softfloat"
+       return ""
+
index de805b9a4bc9cee8e8a089b32349e14df2a61f29..ba46342ae76b48712122086e9fdee3a206a334e1 100644 (file)
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.alsa-project.org"
 SECTION = "libs/multimedia"
 LICENSE = "GPL"
 
-PR = "r1"
+PR = "r2"
 
 # configure.in sets -D__arm__ on the command line for any arm system
 # (not just those with the ARM instruction set), this should be removed,
@@ -17,6 +17,9 @@ SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2 \
 
 inherit autotools pkgconfig
 
+require alsa-fpu.inc
+EXTRA_OECONF += "${@get_alsa_fpu_setting(bb, d)} "
+
 EXTRA_OECONF = "--with-cards=pdaudiocf --with-oss=yes"
 
 do_stage () {