]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-gst: Fix the configure patch & add LIC_FILE_CHKSUM
authorSaul Wold <sgw@linux.intel.com>
Mon, 15 Nov 2010 22:59:36 +0000 (14:59 -0800)
committerSaul Wold <Saul.Wold@intel.com>
Thu, 18 Nov 2010 21:30:25 +0000 (13:30 -0800)
Fixed the acinclude.m4 patch for the py_prefix to correct a host contamination check
Added LIC_FILE_CHKSUM for COPYING
LICENSE Update

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/python/python-gst/python-path.patch
meta/recipes-devtools/python/python-gst_0.10.19.bb

index af5badd4d9bf11d2ebd5d247f13bd75714e6026e..00bab2c56523479811900398d255b1cf5aad2e79 100644 (file)
@@ -1,8 +1,8 @@
-Index: gst-python-0.10.18/acinclude.m4
+Index: gst-python-0.10.19/acinclude.m4
 ===================================================================
---- gst-python-0.10.18.orig/acinclude.m4
-+++ gst-python-0.10.18/acinclude.m4
-@@ -43,6 +43,12 @@ AC_DEFUN([AM_CHECK_PYTHON_HEADERS],
+--- gst-python-0.10.19.orig/acinclude.m4       2010-04-21 15:23:44.000000000 -0700
++++ gst-python-0.10.19/acinclude.m4    2010-11-15 14:43:00.642994001 -0800
+@@ -43,6 +43,13 @@
  [AC_REQUIRE([AM_PATH_PYTHON])
  AC_MSG_CHECKING(for headers required to compile python extensions)
  dnl deduce PYTHON_INCLUDES
@@ -11,11 +11,12 @@ Index: gst-python-0.10.18/acinclude.m4
 +      [  --with-python-includes=DIR  path to Python includes], py_exec_prefix=$withval)
 +if test x$py_exec_prefix != x; then
 +PYTHON_INCLUDES="-I${py_exec_prefix}/include/python${PYTHON_VERSION}"
++py_prefix="${py_exec_prefix}"
 +else
  py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
  py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
  if $PYTHON-config --help 2>/dev/null; then
-@@ -53,6 +59,7 @@ else
+@@ -53,6 +60,7 @@
      PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
    fi
  fi
index cb2147cc9a6939b334b1002c63a4b36e41de5894..6afc3bac225a6128e075c64b99550b445b21569e 100644 (file)
@@ -1,6 +1,6 @@
 DESCRIPTION = "Python Gstreamer bindings"
 SECTION = "devel/python"
-LICENSE = "LGPL"
+LICENSE = "LGPLv2.1"
 DEPENDS = "gstreamer gst-plugins-base python-pygobject"
 RDEPENDS += "python-pygtk"
 PR = "r0"
@@ -9,6 +9,8 @@ SRC_URI = "http://gstreamer.freedesktop.org/src/gst-python/gst-python-${PV}.tar.
            file://python-path.patch"
 S = "${WORKDIR}/gst-python-${PV}"
 
+LIC_FILES_CHKSUM = "file://COPYING;md5=39ff67e932b7bdfa9b78bad67151690b"
+
 inherit autotools distutils-base pkgconfig
 
 EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"