]> code.ossystems Code Review - openembedded-core.git/commitdiff
libtool-cross/native: Force usage of bash due to sstate inconsistencies
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 23 Jan 2014 12:10:01 +0000 (12:10 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 3 Jul 2014 13:55:42 +0000 (14:55 +0100)
Scenario:
a) libtool script is built on system with bash as /bin/sh
b) machine B installs sstate from build a)
c) machine B has dash as /bin/sh

In this scenario, the script fails to work properly since its expecting
/bin/sh to have bash like syntax and it no longer does have it.

This patch forces the configure process to use /bin/bash, not /bin/sh
and hence allows the scripts to work correctly when used from sstate.

(From OE-Core rev: 24d5b449e5f4d91119f0d8e13c457618811aadfc)

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/libtool/libtool-cross_2.4.2.bb
meta/recipes-devtools/libtool/libtool-native_2.4.2.bb

index 34aae0bf1390c168ad8fa63cd09f3a5c220f4b5b..72fad37eaf3d96c04f9aa1bb2091051f3e5841d0 100644 (file)
@@ -39,3 +39,5 @@ libtoolcross_sysroot_preprocess () {
 }
 
 SSTATE_SCAN_FILES += "libtoolize *-libtool"
+
+export CONFIG_SHELL="/bin/bash"
index df73f08e99ebae3b8bd1660325bfd75c3dd5c03f..f1051d84f3baaf978c9a1542324154da6c96862d 100644 (file)
@@ -22,3 +22,4 @@ do_install () {
        install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/${HOST_SYS}-libtool
 }
 
+export CONFIG_SHELL="/bin/bash"