]> code.ossystems Code Review - openembedded-core.git/commitdiff
mtools: Drop GCONV_PATH manipulation
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 7 Mar 2016 12:04:57 +0000 (12:04 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 7 Mar 2016 12:41:09 +0000 (12:41 +0000)
Now that nativesdk-glibc handles GCONV_PATH itself we don't need to do
this here. This unbreaks mtools for the native case without uninative
since the existing patch wasn't nativesdk specific.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/mtools/mtools_3.9.9.bb
meta/recipes-devtools/mtools/mtools_4.0.18.bb

index 26d52a984264635f2591fd2ed2aabab8666c2c1b..3423917d004f1586c10374ad7eed8ae8f650475a 100644 (file)
@@ -51,8 +51,3 @@ do_install_prepend () {
     mkdir -p ${D}/${bindir}
     mkdir -p ${D}/${datadir}
 }
-
-do_install_append_class-native () {
-    create_wrapper ${D}${bindir}/mcopy \
-        GCONV_PATH=${libdir}/gconv
-}
index 479fd329751094e927b0b8de3c455f5852c5841e..efde547e263b2379e34592bc77d025648500cb27 100644 (file)
@@ -48,8 +48,3 @@ do_install_prepend () {
     mkdir -p ${D}/${bindir}
     mkdir -p ${D}/${datadir}
 }
-
-do_install_append_class-native () {
-    create_wrapper ${D}${bindir}/mcopy \
-        GCONV_PATH=${libdir}/gconv
-}