]> code.ossystems Code Review - openembedded-core.git/commitdiff
gobject-introspection: Update revision
authorRichard Purdie <rpurdie@linux.intel.com>
Wed, 19 Aug 2009 16:07:42 +0000 (17:07 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 19 Aug 2009 16:07:42 +0000 (17:07 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/conf/distro/include/poky-fixed-revisions.inc
meta/packages/gnome/gobject-introspection/configure.patch [new file with mode: 0644]
meta/packages/gnome/gobject-introspection/pathfix.patch
meta/packages/gnome/gobject-introspection_git.bb

index 46017b94cc5e311a6621c3c3ad87aac2d8b08bbd..130272722853348ecf14abd7a4041def349cd72a 100644 (file)
@@ -191,8 +191,9 @@ SRCREV_pn-gnet = "495"
 SRCREV_pn-tasks ?= "430"
 SRCREV_pn-librsvg ?= "1193"
 SRCREV_pn-qemugl = "d888bbc723c00d197d34a39b5b7448660ec1b1c0"
-SRCREV_pn-gobject-introspection = "c54f10f4caef35b42229c48951ee647ef05ab557"
-SRCREV_pn-gobject-introspection-native = "c54f10f4caef35b42229c48951ee647ef05ab557"
+SRCREV_pn-gobject-introspection = "efa7266bcf78478ce62e8dd778a4f0417bfd4d15"
+#c54f10f4caef35b42229c48951ee647ef05ab557"
+SRCREV_pn-gobject-introspection-native = "efa7266bcf78478ce62e8dd778a4f0417bfd4d15"
 
 SRCREVMOZILLAHEADLESS ?= "f4348fd85697"
 
diff --git a/meta/packages/gnome/gobject-introspection/configure.patch b/meta/packages/gnome/gobject-introspection/configure.patch
new file mode 100644 (file)
index 0000000..c441799
--- /dev/null
@@ -0,0 +1,25 @@
+Index: git/common.mk
+===================================================================
+--- git.orig/common.mk 2009-08-19 11:11:26.000000000 +0100
++++ git/common.mk      2009-08-19 11:12:05.000000000 +0100
+@@ -4,7 +4,7 @@
+       UNINSTALLED_INTROSPECTION_SRCDIR=$(top_srcdir) \
+       UNINSTALLED_INTROSPECTION_BUILDDIR=$(top_builddir)
+ SCANNER_ARGS = -v --add-include-path=$(top_builddir)/gir --add-include-path=.
+-SCANNER = $(AM_V_GEN) env LPATH=.libs $(CHECK_DEBUG) $(SCANNER_ENV) $(SCANNER_BIN) $(SCANNER_ARGS)
++SCANNER = $(AM_V_GEN) env LPATH=.libs $(CHECK_DEBUG) $(SCANNER_ENV) g-ir-scanner $(SCANNER_ARGS)
+ SCANNER_LIBS = \
+       $(top_srcdir)/giscanner/*.py \
+       $(top_builddir)/giscanner/libgiscanner.la \
+Index: git/configure.ac
+===================================================================
+--- git.orig/configure.ac      2009-08-19 11:11:26.000000000 +0100
++++ git/configure.ac   2009-08-19 11:11:28.000000000 +0100
+@@ -201,7 +201,6 @@
+       pyexecdir=`echo $pyexecdir | tr '\\\\' '/'`
+       ;;
+ esac
+-AM_CHECK_PYTHON_HEADERS(,AC_MSG_ERROR([Python headers not found]))
+ AC_CONFIG_FILES([
+ Makefile
index d640ddba17d654949df287977b76b058b61348ca..b4582e2eaa767e25d3821800d81aa60398d82b8a 100644 (file)
@@ -1,22 +1,22 @@
 Index: git/gir/Makefile.am
 ===================================================================
---- git.orig/gir/Makefile.am   2009-05-12 14:37:40.000000000 +0100
-+++ git/gir/Makefile.am        2009-05-12 14:37:40.000000000 +0100
-@@ -40,7 +40,7 @@
+--- git.orig/gir/Makefile.am   2009-08-19 11:11:26.000000000 +0100
++++ git/gir/Makefile.am        2009-08-19 11:12:45.000000000 +0100
+@@ -41,7 +41,7 @@
            -I$(GLIB_LIBDIR)/glib-2.0/include \
            -DGETTEXT_PACKAGE=Dummy \
            -D__G_I18N_LIB_H__ \
 -          $(GLIB_LIBDIR)/glib-2.0/include/glibconfig.h \
 +          $(GLIB_INCLUDEDIR)/glibconfig.h \
            $(srcdir)/glib-2.0.c \
+           -DGLIB_COMPILATION \
            $(GLIB_INCLUDEDIR)/glib/*.h
-       $(SCANNER) $(SCANNER_ARGS) \
 Index: git/giscanner/dumper.py
 ===================================================================
---- git.orig/giscanner/dumper.py       2009-05-12 14:37:40.000000000 +0100
-+++ git/giscanner/dumper.py    2009-05-12 14:37:40.000000000 +0100
-@@ -79,7 +79,7 @@
-         self._tmpdir = tempfile.mkdtemp('', 'tmp-introspect')
+--- git.orig/giscanner/dumper.py       2009-08-19 11:11:26.000000000 +0100
++++ git/giscanner/dumper.py    2009-08-19 11:12:45.000000000 +0100
+@@ -82,7 +82,7 @@
+         self._tmpdir = tempfile.mkdtemp('', 'tmp-introspect', dir=os.getcwd())
  
          self._compiler_cmd = os.environ.get('CC', 'gcc')
 -        self._linker_cmd = os.environ.get('LD', self._compiler_cmd)
@@ -26,9 +26,9 @@ Index: git/giscanner/dumper.py
          self._uninst_srcdir = os.environ.get(
 Index: git/giscanner/scannermain.py
 ===================================================================
---- git.orig/giscanner/scannermain.py  2009-05-12 14:37:40.000000000 +0100
-+++ git/giscanner/scannermain.py       2009-05-12 14:37:40.000000000 +0100
-@@ -282,6 +282,7 @@
+--- git.orig/giscanner/scannermain.py  2009-08-19 11:11:26.000000000 +0100
++++ git/giscanner/scannermain.py       2009-08-19 11:12:45.000000000 +0100
+@@ -283,6 +283,7 @@
      shown_include_warning = False
      for include in options.includes:
          if os.sep in include:
@@ -36,18 +36,3 @@ Index: git/giscanner/scannermain.py
              raise ValueError("Invalid include path %r" % (include, ))
          include_obj = Include.from_string(include)
          transformer.register_include(include_obj)
-Index: git/configure.ac
-===================================================================
---- git.orig/configure.ac      2009-05-12 14:37:40.000000000 +0100
-+++ git/configure.ac   2009-05-12 14:38:01.000000000 +0100
-@@ -191,7 +191,9 @@
- esac
- AM_CHECK_PYTHON_HEADERS(,AC_MSG_ERROR([Python headers not found]))
--SHAVE_INIT([scripts])
-+SHAVE_SAVED_LIBTOOL=$LIBTOOL
-+AC_SUBST(SHAVE_SAVED_LIBTOOL)
-+
- AC_CONFIG_FILES([
- Makefile
- gir/Makefile
index e098044ec441aea49a3695c24095e49686065c6e..9c3201cbd55e630fe9b7dc539f2fb00c6c4b0586 100644 (file)
@@ -1,8 +1,12 @@
 SRC_URI = "git://git.gnome.org/gobject-introspection;protocol=git \
+           file://configure.patch;patch=1 \
            file://pathfix.patch;patch=1"
 
+SRC_URI_virtclass-native = "git://git.gnome.org/gobject-introspection;protocol=git \
+                            file://pathfix.patch;patch=1"
+
 PV = "0.0+git${SRCREV}"
-PR = "r1"
+PR = "r3"
 
 S = "${WORKDIR}/git"