]> code.ossystems Code Review - openembedded-core.git/commitdiff
python: fix RDEPENDS on several recipes, due to non-existent packages
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>
Fri, 4 Aug 2017 21:14:02 +0000 (14:14 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 20 Jan 2018 22:31:13 +0000 (22:31 +0000)
The packaging has been altered slightly so ensure the dependencies are all still
valid.

Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
18 files changed:
meta/recipes-core/libxml/libxml2_2.9.7.bb
meta/recipes-devtools/bootchart2/bootchart2_0.14.8.bb
meta/recipes-devtools/dnf/dnf_2.7.5.bb
meta/recipes-devtools/gdb/gdb-cross-canadian.inc
meta/recipes-devtools/opkg-utils/opkg-utils_0.3.5.bb
meta/recipes-devtools/python-numpy/python3-numpy_1.13.3.bb
meta/recipes-devtools/python/python-async.inc
meta/recipes-devtools/python/python-git.inc
meta/recipes-devtools/python/python-gitdb.inc
meta/recipes-devtools/python/python-scons_3.0.1.bb
meta/recipes-devtools/python/python-setuptools.inc
meta/recipes-devtools/python/python-smmap.inc
meta/recipes-devtools/python/python3-pip_9.0.1.bb
meta/recipes-devtools/python/python3-pygobject_3.26.1.bb
meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb
meta/recipes-graphics/piglit/piglit_git.bb
meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
meta/recipes-rt/rt-tests/rt-tests_1.1.bb

index 85bfecae8895089f19df6c9deaf197e6b233d269..2fb90a68a8f659996f1d40280a57cf40dcdfc724 100644 (file)
@@ -40,7 +40,7 @@ inherit autotools pkgconfig binconfig-disabled ptest
 
 inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
 
-RDEPENDS_${PN}-ptest += "make ${@bb.utils.contains('PACKAGECONFIG', 'python', 'libgcc python3-core python3-argparse python3-logging python3-shell python3-signal python3-stringold python3-threading python3-unittest ${PN}-python', '', d)}"
+RDEPENDS_${PN}-ptest += "make ${@bb.utils.contains('PACKAGECONFIG', 'python', 'libgcc python3-core python3-logging python3-shell  python3-stringold python3-threading python3-unittest ${PN}-python', '', d)}"
 
 RDEPENDS_${PN}-python += "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3-core', '', d)}"
 
index a3101351ee7c063ebe42c0eb80435262a8403a96..c047be1e85be08c4c863cad39fee6053a26a6de6 100644 (file)
@@ -139,7 +139,7 @@ do_install () {
 
 PACKAGES =+ "pybootchartgui"
 FILES_pybootchartgui += "${PYTHON_SITEPACKAGES_DIR}/pybootchartgui ${bindir}/pybootchartgui"
-RDEPENDS_pybootchartgui = "python3-pycairo python3-compression python3-image python3-textutils python3-shell python3-compression python3-codecs"
+RDEPENDS_pybootchartgui = "python3-pycairo python3-compression python3-image python3-shell python3-compression python3-codecs"
 RDEPENDS_${PN}_class-target += "${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'sysvinit-pidof', 'procps', d)}"
 RDEPENDS_${PN}_class-target += "lsb"
 DEPENDS_append_class-native = " python3-pycairo-native"
index fbd3bd45719b99e9d3111f9c23fe1645509cfa13..b88ddb445a7f50093c86650ccaef1e8c1cc37d6f 100644 (file)
@@ -25,8 +25,30 @@ DEPENDS += "libdnf librepo libcomps python3-iniparse"
 EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
 
 BBCLASSEXTEND = "native nativesdk"
-RDEPENDS_${PN}_class-target += "python3-core python3-codecs python3-netclient python3-email python3-threading python3-distutils librepo python3-shell python3-subprocess libcomps libdnf python3-sqlite3 python3-compression python3-rpm python3-iniparse python3-json python3-importlib python3-curses python3-argparse python3-misc python3-gpg"
-# Recommend gnupg so that GPG signature check on repository metadata is possible
+
+RDEPENDS_${PN}_class-target += " \
+  python3-core \
+  python3-codecs \
+  python3-netclient \
+  python3-email \
+  python3-threading \
+  python3-distutils \
+  python3-logging \
+  python3-fcntl \
+  librepo \
+  python3-shell \
+  libcomps \
+  libdnf \
+  python3-sqlite3 \
+  python3-compression \
+  python3-rpm \
+  python3-iniparse \
+  python3-json \
+  python3-curses \
+  python3-misc \
+  python3-gpg \
+  "
+
 RRECOMMENDS_${PN}_class-target += "gnupg"
 
 # Create a symlink called 'dnf' as 'make install' does not do it, but
index 3ff1989538827eb2ffd311c180f16ebb7b569bb4..4fc6747d9da38e5091baf002ce609369c1485e0e 100644 (file)
@@ -13,9 +13,9 @@ GDBPROPREFIX = "--program-prefix='${TARGET_PREFIX}'"
 # Overrides PACKAGECONFIG variables in gdb-common.inc
 PACKAGECONFIG ??= "python readline"
 PACKAGECONFIG[python] = "--with-python=${WORKDIR}/python,--without-python,nativesdk-python3, \
-                         nativesdk-python3-core nativesdk-python3-lang nativesdk-python3-re \
+                         nativesdk-python3-core \
                          nativesdk-python3-codecs nativesdk-python3-netclient \
-                         nativesdk-python3-importlib"
+                         "
 PACKAGECONFIG[readline] = "--with-system-readline,--without-system-readline,nativesdk-readline"
 
 SSTATE_DUPWHITELIST += "${STAGING_DATADIR}/gdb"
index 514ba7912a351d23c27fdb7c142e351393fa16fd..e9ba9de09487352d95f8b5b4dcdb0c3f2d74007b 100644 (file)
@@ -20,7 +20,7 @@ SRC_URI[sha256sum] = "7f4b08912e26a3f4f6f423f3b4e7157a73b1f3a7483fc59b216d1a80b5
 TARGET_CC_ARCH += "${LDFLAGS}"
 
 # For native builds we use the host Python
-PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-subprocess python3-pickle python3-compression python3-textutils python3-stringold"
+PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-pickle python3-compression python3-stringold"
 PYTHONRDEPS_class-native = ""
 
 PACKAGECONFIG = "python update-alternatives"
index 42b2a18a5b88810eb21057cc808b422c42833eaf..277c21f9da43b1a50cbf61e1c2647db8b5633cdc 100644 (file)
@@ -102,11 +102,9 @@ RDEPENDS_${PN} = "python3-unittest \
                   python3-pydoc \
                   python3-pkgutil \
                   python3-email \
-                  python3-subprocess \
                   python3-compression \
                   python3-ctypes \
                   python3-threading \
-                  python3-textutils \
 "
 
 RDEPENDS_${PN}_class-native = ""
index 0874667e0c3dcbf10d088820ec2290b0d5db6299..6664ab013c7b0a479ea273b19658c4dc9d0b23de 100644 (file)
@@ -9,6 +9,6 @@ inherit pypi
 SRC_URI[md5sum] = "9b06b5997de2154f3bc0273f80bcef6b"
 SRC_URI[sha256sum] = "ac6894d876e45878faae493b0cf61d0e28ec417334448ac0a6ea2229d8343051"
 
-RDEPENDS_${PN} += "${PYTHON_PN}-threading ${PYTHON_PN}-lang"
+RDEPENDS_${PN} += "${PYTHON_PN}-threading"
 
 BBCLASSEXTEND = "nativesdk"
index bef08eb74ef671caf15189a47a3e9cbd1d46bb7d..8d3769396008d47aca909b0d3b5fe7e5aefb1dc0 100644 (file)
@@ -17,19 +17,14 @@ SRC_URI[sha256sum] = "ad61bc25deadb535b047684d06f3654c001d9415e1971e51c9c20f5b51
 
 DEPENDS = "${PYTHON_PN}-gitdb"
 
-RDEPENDS_${PN} += "${PYTHON_PN}-argparse \
+RDEPENDS_${PN} += " \
                    ${PYTHON_PN}-datetime \
-                   ${PYTHON_PN}-enum \
                    ${PYTHON_PN}-gitdb \
                    ${PYTHON_PN}-io \
-                   ${PYTHON_PN}-lang \
                    ${PYTHON_PN}-logging \
                    ${PYTHON_PN}-math \
                    ${PYTHON_PN}-netclient \
-                   ${PYTHON_PN}-re \
-                   ${PYTHON_PN}-shell \
                    ${PYTHON_PN}-stringold \
-                   ${PYTHON_PN}-subprocess \
                    ${PYTHON_PN}-unittest \
                    ${PYTHON_PN}-unixadmin \
                    git \
index b32b869a02f0253c1e02f95e928a9227b2b4a93d..2d5292e5d496854165fd3ea485210e50e34bfe97 100644 (file)
@@ -17,7 +17,6 @@ RDEPENDS_${PN} += "${PYTHON_PN}-async \
                    ${PYTHON_PN}-compression \
                    ${PYTHON_PN}-crypt \
                    ${PYTHON_PN}-io \
-                   ${PYTHON_PN}-lang \
                    ${PYTHON_PN}-mmap \
                    ${PYTHON_PN}-shell \
                    ${PYTHON_PN}-smmap \
index 2f75b08d25446b2df96a6432586c10ce6b16077c..d5084b2d16f72ee3fd0e64fbdd70e45411aef451 100644 (file)
@@ -18,5 +18,4 @@ RDEPENDS_${PN} = "\
   python-subprocess \
   python-shell \
   python-pprint \
-  python-importlib \
   "
index d6eeeba2e3788e2c413f24e37160c4cc8a0bc03c..54b7c300e05f7d17527b8fe035e6ae0a44e5dbb3 100644 (file)
@@ -30,15 +30,12 @@ RDEPENDS_${PN} = "\
   ${PYTHON_PN}-distutils \
   ${PYTHON_PN}-email \
   ${PYTHON_PN}-html \
-  ${PYTHON_PN}-importlib \
   ${PYTHON_PN}-netserver \
   ${PYTHON_PN}-numbers \
   ${PYTHON_PN}-pkgutil \
   ${PYTHON_PN}-plistlib \
   ${PYTHON_PN}-shell \
-  ${PYTHON_PN}-subprocess \
   ${PYTHON_PN}-stringold \
-  ${PYTHON_PN}-textutils \
   ${PYTHON_PN}-threading \
   ${PYTHON_PN}-unittest \
   ${PYTHON_PN}-xml \
index 32438350c12db934dec369efc38be698889daa0d..55aa516e0afc2cd3c8aaae9bf96c859ac1a15823 100644 (file)
@@ -13,7 +13,6 @@ SRC_URI[md5sum] = "d7932d5ace206bf4ae15198cf36fb6ab"
 SRC_URI[sha256sum] = "0e2b62b497bd5f0afebc002eda4d90df9d209c30ef257e8673c90a6b5c119d62"
 
 RDEPENDS_${PN} += "${PYTHON_PN}-codecs \
-                   ${PYTHON_PN}-lang \
                    ${PYTHON_PN}-mmap \
 "
 BBCLASSEXTEND = "nativesdk"
index 4ce13da4102758c73801c5009b25d67672c3a266..cd849eb08eb23c1ed3b264dff839e5da7c55c5b8 100644 (file)
@@ -37,7 +37,6 @@ do_install_append() {
 RDEPENDS_${PN} = "\
   python3-compile \
   python3-io \
-  python3-enum \
   python3-html \
   python3-json \
   python3-netserver \
index 0405b44f177ab3ba3b8cc88f52cfbcf29b3d43bf..91f2d53d784b1ebd01e310a363198e587bd46ddb 100644 (file)
@@ -24,7 +24,7 @@ PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wa
 # we don't link against python3-pycairo -> RDEPENDS
 PACKAGECONFIG[cairo] = "--enable-cairo,--disable-cairo,cairo python3-pycairo, python3-pycairo"
 
-RDEPENDS_${PN} += "python3-setuptools python3-importlib"
+RDEPENDS_${PN} += "python3-setuptools"
 
 BBCLASSEXTEND = "native"
 PACKAGECONFIG_class-native = ""
index 943ca5f89dc4605593317c0ed8bf422b6409bdd5..1a9ad5cc2b91c1bc52bc50c6641265c0e05dc5d5 100644 (file)
@@ -1,6 +1,6 @@
 SUMMARY = "Qemu helper scripts"
 LICENSE = "GPLv2"
-RDEPENDS_${PN} = "nativesdk-qemu nativesdk-python3-subprocess \
+RDEPENDS_${PN} = "nativesdk-qemu \
                   nativesdk-python3-shell nativesdk-python3-fcntl \
                 "
 
index 06c5021eb7651a67c02d69dddd356161a8db2b9b..2839f1d2852c6245542b7644422d7d6806e56189 100644 (file)
@@ -44,9 +44,9 @@ do_configure_prepend() {
 OECMAKE_TARGET_INSTALL = "install/strip"
 
 RDEPENDS_${PN} = "waffle python3 python3-mako python3-json \
-       python3-subprocess python3-misc python3-importlib \
+       python3-misc \
        python3-unixadmin python3-xml python3-multiprocessing \
-       python3-six python3-shell python3-io python3-argparse \
+       python3-six python3-shell python3-io \
        python3-netserver mesa-demos bash \
        "
 
index 012b2dd0a7db1dc4d70f280da1814d7d4699fbdc..5f61c4ecddc7a6d49df2ab73bc92ddc9775020bc 100644 (file)
@@ -22,5 +22,5 @@ do_install() {
 }
 
 FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"
-RDEPENDS_${PN} = "python3 python3-subprocess python3-textutils"
+RDEPENDS_${PN} = "python3-core "
 RRECOMMENDS_${PN} = "kernel-module-hwlat-detector"
index 4336c50d6313c6613bdcf6a36dbe269f55ba294b..496f04fdbaeed08dcb4ac3f619ad03effc07b694 100644 (file)
@@ -26,6 +26,6 @@ do_install_ptest() {
         cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH}
 }
 
-RDEPENDS_${PN}-ptest += " stress python3 python3-subprocess python3-multiprocessing python3-datetime python3-re python3-lang python3-misc"
+RDEPENDS_${PN}-ptest += " stress python3 python3-multiprocessing python3-datetime python3-misc"
 
 FILES_${PN} += "${prefix}/src/backfire"