]> code.ossystems Code Review - openembedded-core.git/commitdiff
dpkg: Update to use perlnative
authorSaul Wold <sgw@linux.intel.com>
Fri, 5 Aug 2011 01:07:08 +0000 (18:07 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 5 Aug 2011 16:13:00 +0000 (17:13 +0100)
[YOCTO #1298]

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/dpkg/dpkg.inc
meta/recipes-devtools/dpkg/dpkg_1.15.8.7.bb

index c8ff18291d77d3ae87db30e90810059cad3e213c..041eda9d46725925adfbeb92a1727ed20c9bd0e2 100644 (file)
@@ -2,6 +2,8 @@ DESCRIPTION = "Package maintenance system for Debian."
 LICENSE = "GPL"
 SECTION = "base"
 
+INC_PR = "r4"
+
 SRC_URI = "${DEBIAN_MIRROR}/main/d/dpkg/dpkg_${PV}.tar.bz2 \
            file://ignore_extra_fields.patch;patch=1"
 
@@ -14,7 +16,7 @@ S = "${WORKDIR}/${BPN}-${PV}"
 
 PARALLEL_MAKE = ""
 
-inherit autotools gettext
+inherit autotools gettext perlnative
 
 DPKG_INIT_POSITION = "98"
 
index 22edab858eebb0ddd6f02d8e72e4bde13ca7de27..48b62780d4e0278a68bc5d194f27f77ca7a9f58a 100644 (file)
@@ -8,7 +8,7 @@ SRC_URI += "file://noman.patch;patch=1 \
 SRC_URI[md5sum] = "d1731d4147c1ea3b537a4d094519a6dc"
 SRC_URI[sha256sum] = "1ec1376471b04717a4497e5d7a27cd545248c92116898ce0c53ced8ea94267b5"
 
-PR = "r3"
+PR = "${INC_PR}.0"
 
 EXTRA_OECONF = "--without-static-progs \
                --without-dselect \