]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: Tweak for mips n64
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 10 Dec 2021 12:03:42 +0000 (12:03 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 12 Dec 2021 11:27:19 +0000 (11:27 +0000)
With the changes to binutils, perf's direct calls to ld break for mips n64.
We already have tweaks for n32 so match those with the ones for n64.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/perf/perf.bb

index 7bbc1ad70c59e1827c0b26ca3effd6db43b8fcbf..ec0c6efe15f3f6a5d19f60f9b20b37fd0be03df5 100644 (file)
@@ -125,9 +125,11 @@ PERF_SRC ?= "Makefile \
 
 PERF_EXTRA_LDFLAGS = ""
 
-# MIPS N32
+# MIPS N32/N64
 PERF_EXTRA_LDFLAGS:mipsarchn32eb = "-m elf32btsmipn32"
 PERF_EXTRA_LDFLAGS:mipsarchn32el = "-m elf32ltsmipn32"
+PERF_EXTRA_LDFLAGS:mipsarchn64eb = "-m elf64btsmip"
+PERF_EXTRA_LDFLAGS:mipsarchn64el = "-m elf64ltsmip"
 
 do_compile() {
        # Linux kernel build system is expected to do the right thing