]> code.ossystems Code Review - openembedded-core.git/commitdiff
tzdata: remove exit 0 from pkg_postinst
authorMaxime Roussin-B?langer <maxime.roussinbelanger@gmail.com>
Wed, 15 Apr 2020 16:24:46 +0000 (12:24 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 24 Apr 2020 12:57:01 +0000 (13:57 +0100)
Documentation says that if you exit 0 in a pkg_postinst it will marked as
installed.
If you exit 0, before running postinst-intercepts defer_to_first_boot, the
pkg_postinst_ontarget script will not be present on target.

The "exit 0" in tzdata makes it difficult to have a bbappend with a
pkg_postinst_target step when you have `INSTALL_TIMEZONE_FILE = 0`

Signed-off-by: Maxime Roussin-Bélanger <maxime.roussinbelanger@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/timezone/tzdata.bb

index 1e2d9bd1b9e50bb48bbb66b7816e5b7a73790755..1e2b440fb0e901a97de859ab28361c9b676a5fe7 100644 (file)
@@ -60,12 +60,8 @@ pkg_postinst_${PN} () {
        if [ -e ${src} ] ; then
                tz=$(sed -e 's:#.*::' -e 's:[[:space:]]*::g' -e '/^$/d' "${src}")
        fi
-       
-       if [ -z "${tz}" ] ; then
-               exit 0
-       fi
-       
-       if [ ! -e "$D${datadir}/zoneinfo/${tz}" ] ; then
+
+       if [ ! -z "${tz}" -a ! -e "$D${datadir}/zoneinfo/${tz}" ] ; then
                echo "You have an invalid TIMEZONE setting in ${src}"
                echo "Your ${etc_lt} has been reset to Universal; enjoy!"
                tz="Universal"