]> code.ossystems Code Review - openembedded-core.git/commitdiff
gdb: Upgrade to 7.12.1
authorKhem Raj <raj.khem@gmail.com>
Mon, 13 Feb 2017 18:00:11 +0000 (10:00 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 23 Feb 2017 20:29:13 +0000 (12:29 -0800)
Drop already applied patches

(From OE-Core rev: 233641857bdc4071e5cb9a25206def880eb2754d)

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/gdb/gdb-7.12.1.inc [moved from meta/recipes-devtools/gdb/gdb-7.12.inc with 83% similarity]
meta/recipes-devtools/gdb/gdb-cross-canadian_7.12.1.bb [moved from meta/recipes-devtools/gdb/gdb-cross-canadian_7.12.bb with 100% similarity]
meta/recipes-devtools/gdb/gdb-cross_7.12.1.bb [moved from meta/recipes-devtools/gdb/gdb-cross_7.12.bb with 100% similarity]
meta/recipes-devtools/gdb/gdb/cb93dc7f262978bafe36397a41a56e409a302042.patch [deleted file]
meta/recipes-devtools/gdb/gdb_7.12.1.bb [moved from meta/recipes-devtools/gdb/gdb_7.12.bb with 100% similarity]

similarity index 83%
rename from meta/recipes-devtools/gdb/gdb-7.12.inc
rename to meta/recipes-devtools/gdb/gdb-7.12.1.inc
index 7eea65f4fad8bc75c024e76a611b0bbf606214ed..b15a2b583207366590510be5b0ea6adb356d775d 100644 (file)
@@ -15,8 +15,7 @@ SRC_URI = "http://ftp.gnu.org/gnu/gdb/gdb-${PV}.tar.xz \
            file://0008-Use-exorted-definitions-of-SIGRTMIN.patch \
            file://0009-Change-order-of-CFLAGS.patch \
            file://0010-resolve-restrict-keyword-conflict.patch \
-          file://cb93dc7f262978bafe36397a41a56e409a302042.patch \
 "
-SRC_URI[md5sum] = "a0a3a00f7499b0c5278ba8676745d180"
-SRC_URI[sha256sum] = "834ff3c5948b30718343ea57b11cbc3235d7995c6a4f3a5cecec8c8114164f94"
+SRC_URI[md5sum] = "193453347ddced7acb6b1cd2ee8f2e4b"
+SRC_URI[sha256sum] = "4607680b973d3ec92c30ad029f1b7dbde3876869e6b3a117d8a7e90081113186"
 
diff --git a/meta/recipes-devtools/gdb/gdb/cb93dc7f262978bafe36397a41a56e409a302042.patch b/meta/recipes-devtools/gdb/gdb/cb93dc7f262978bafe36397a41a56e409a302042.patch
deleted file mode 100644 (file)
index 3a42f0a..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-From cb93dc7f262978bafe36397a41a56e409a302042 Mon Sep 17 00:00:00 2001
-From: Yao Qi <yao.qi@linaro.org>
-Date: Mon, 24 Oct 2016 10:59:11 +0100
-Subject: [PATCH] [GDBserver] Fix conversion warning
-
-I got the following warning if I build GDBserver for aarch64_be-linux-gnu,
-
-git/gdb/gdbserver/linux-aarch64-low.c:1539:39: error: invalid conversion from 'void*' to 'uint32_t* {aka unsigned int*}' [-fpermissive]
-   uint32_t *le_buf = xmalloc (byte_len);
-                                       ^
-The patch is to fix the warning.
-
-gdb/gdbserver:
-
-2016-10-24  Yao Qi  <yao.qi@linaro.org>
-
-       PR server/20733
-       * linux-aarch64-low.c (append_insns): Cast the return value to
-       'uint32_t *'.
-
-Upstream-status: Backport
-Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
-
----
- gdb/gdbserver/linux-aarch64-low.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/gdb/gdbserver/linux-aarch64-low.c b/gdb/gdbserver/linux-aarch64-low.c
-index e54a8ba..ae80cdd 100644
---- a/gdb/gdbserver/linux-aarch64-low.c
-+++ b/gdb/gdbserver/linux-aarch64-low.c
-@@ -1536,7 +1536,7 @@ append_insns (CORE_ADDR *to, size_t len, const uint32_t *buf)
- {
-   size_t byte_len = len * sizeof (uint32_t);
- #if (__BYTE_ORDER == __BIG_ENDIAN)
--  uint32_t *le_buf = xmalloc (byte_len);
-+  uint32_t *le_buf = (uint32_t *) xmalloc (byte_len);
-   size_t i;
-   for (i = 0; i < len; i++)
--- 
-2.9.3
-