]> code.ossystems Code Review - openembedded-core.git/commitdiff
glib-2.0: upgrade to 2.28.0
authorRoss Burton <ross.burton@intel.com>
Mon, 7 Oct 2013 17:49:07 +0000 (17:49 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 14 Oct 2013 15:54:32 +0000 (16:54 +0100)
Drop the ptest patches and instead use --enable-installed-tests, updating
run-ptest to invoke gnome-desktop-testing-runner.

Drop the x32 build patch, upstream has integrated a similar fix.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/glib-2.0/glib-2.0/Makefile-ptest.patch [deleted file]
meta/recipes-core/glib-2.0/glib-2.0/glib-2.0_fix_for_x32.patch [deleted file]
meta/recipes-core/glib-2.0/glib-2.0/run-ptest
meta/recipes-core/glib-2.0/glib-2.0_2.38.0.bb [moved from meta/recipes-core/glib-2.0/glib-2.0_2.36.4.bb with 89% similarity]
meta/recipes-core/glib-2.0/glib.inc

diff --git a/meta/recipes-core/glib-2.0/glib-2.0/Makefile-ptest.patch b/meta/recipes-core/glib-2.0/glib-2.0/Makefile-ptest.patch
deleted file mode 100644 (file)
index 40c5b9f..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
-Add 'ptest' target to Makefile, to run tests without checking dependencies.
-Add 'install-ptest' target, to copy needed files to ptest dir.
-
-Signed-off-by: Björn Stenberg <bjst@enea.com>
-Upstream-Status: Pending
----
- Makefile.decl |   43 +++++++++++++++++++++++++++++++++++++++++++
- 1 file changed, 43 insertions(+)
-
---- a/Makefile.decl    2012-03-12 01:42:39.000000000 +0100
-+++ b/Makefile.decl    2012-11-26 13:42:08.436865192 +0100
-@@ -25,6 +25,49 @@
- test-nonrecursive:
- endif
-+ptest: ptest-nonrecursive
-+      @ for subdir in $(SUBDIRS) .; do \
-+          test -d "$$subdir" -a "$$subdir" != "." -a "$$subdir" != "po" && \
-+          ( test -d $$subdir && cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $@ ) \
-+        done
-+
-+ptest-nonrecursive:
-+      @test -z "${TEST_PROGS}" || ${GTESTER} --keep-going --verbose ${TEST_PROGS}
-+
-+install-ptest: install-ptest-nonrecursive
-+      @test -z "$(SUBDIRS)" || for subdir in $(SUBDIRS); do \
-+          test "$$subdir" == "." || \
-+          (cd $$subdir && $(MAKE) DESTDIR=$(DESTDIR)/$$subdir $@ ) \
-+      done
-+
-+# install files used for ptest:
-+# - copy EXTRA_DIST (for test data in glib/tests)
-+# - run dist-hook (for glib/tests/bookmarks/ and glib/tests/markups)
-+# - copy TEST_PROGS (the test programs)
-+# - copy INSTALL_PROGS (for glib/gtester)
-+# - avoid libtool wrappers by copying binaries from .libs
-+# - strip Makefile: target from all Makefiles
-+install-ptest-nonrecursive:
-+      @mkdir -p $(DESTDIR)
-+      @if [ -n "${TEST_PROGS}" ]; then \
-+              if [ -n "${EXTRA_DIST}" ]; then \
-+                      cp ${EXTRA_DIST} $(DESTDIR); \
-+              fi; \
-+              grep -q dist-hook: Makefile && \
-+                      $(MAKE) distdir=$(DESTDIR) dist-hook; \
-+              if [ -d .libs ] ; then \
-+                      cd .libs; \
-+              fi; \
-+              cp ${TEST_PROGS} $(DESTDIR); \
-+      fi;
-+      @if [ -n "${INSTALL_PROGS}" ]; then \
-+              if [ -d .libs ]  ; then \
-+                      cd .libs; \
-+              fi; \
-+              cp ${INSTALL_PROGS} $(DESTDIR); \
-+      fi
-+      @test -f Makefile && sed 's/^Makefile:/_Makefile:/' <Makefile >$(DESTDIR)/Makefile
-+
- # test-report: run tests in subdirs and generate report
- # perf-report: run tests in subdirs with -m perf and generate report
- # full-report: like test-report: with -m perf and -m slow
diff --git a/meta/recipes-core/glib-2.0/glib-2.0/glib-2.0_fix_for_x32.patch b/meta/recipes-core/glib-2.0/glib-2.0/glib-2.0_fix_for_x32.patch
deleted file mode 100644 (file)
index 0c243cd..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-Upstream-Status: Pending
-
-Pass CC & CFLAGS vars so that tune parameters get used.
-This fixes compilation with x32 toolchain.
-
-Received this patch from H.J. Lu <hjl.tools@gmail.com>
-Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com> 2011/07/13
-
-Index: glib-2.30.0/glib/Makefile.am
-===================================================================
---- glib-2.30.0.orig/glib/Makefile.am
-+++ glib-2.30.0/glib/Makefile.am
-@@ -359,10 +359,10 @@ INSTALL_PROGS=
- if ENABLE_DTRACE
- glib_probes.h: glib_probes.d Makefile
--      $(AM_V_GEN) $(DTRACE) -C -h -s $< -o $@.tmp
-+      $(AM_V_GEN) CFLAGS="$(CFLAGS)" $(DTRACE) -C -h -s $< -o $@.tmp
-       @$(SED) -e "s,define STAP_HAS_SEMAPHORES 1,undef STAP_HAS_SEMAPHORES," < $@.tmp > $@ && rm -f $@.tmp
- glib_probes.o: glib_probes.d Makefile
--      $(AM_V_GEN) $(DTRACE) -G -s $< -o $@
-+      $(AM_V_GEN) CFLAGS="$(CFLAGS)" $(DTRACE) -G -s $< -o $@
- BUILT_SOURCES += glib_probes.h glib_probes.o
- CLEANFILES += glib_probes.h glib_probes.h.tmp
- libglib_2_0_la_LIBADD += glib_probes.o
-Index: glib-2.30.0/gobject/Makefile.am
-===================================================================
---- glib-2.30.0.orig/gobject/Makefile.am
-+++ glib-2.30.0/gobject/Makefile.am
-@@ -141,10 +141,10 @@ gobject_c_sources = \
- if ENABLE_DTRACE
- gobject_probes.h: gobject_probes.d Makefile
--      $(AM_V_GEN) $(DTRACE) -C -h -s $< -o $@.tmp
-+      $(AM_V_GEN) CFLAGS="$(CFLAGS)" $(DTRACE) -C -h -s $< -o $@.tmp
-       @$(SED) -e "s,define STAP_HAS_SEMAPHORES 1,undef STAP_HAS_SEMAPHORES," < $@.tmp > $@ && rm -f $@.tmp
- gobject_probes.o: gobject_probes.d Makefile
--      $(AM_V_GEN) $(DTRACE) -G -s $< -o $@
-+      $(AM_V_GEN) CFLAGS="$(CFLAGS)" $(DTRACE) -G -s $< -o $@
- BUILT_SOURCES += gobject_probes.h gobject_probes.o
- CLEANFILES += gobject_probes.h
- libgobject_2_0_la_LIBADD += gobject_probes.o
index 3deb5869991956e99535567d131a9f603bfbcf75..130ae09b6c8d0977ffeccc4ae01379bdd4a8394e 100644 (file)
@@ -1,3 +1,3 @@
-#!/bin/sh
+#! /bin/sh
 
-make -k ptest
+gnome-desktop-testing-runner glib
similarity index 89%
rename from meta/recipes-core/glib-2.0/glib-2.0_2.36.4.bb
rename to meta/recipes-core/glib-2.0/glib-2.0_2.38.0.bb
index d62c1fd36e8967d62829e1bf60ef36827d337ee2..4b9b1129e255806b483c9403b435085e0c8e1519 100644 (file)
@@ -10,22 +10,21 @@ SHRT_VER = "${@oe.utils.trim_version("${PV}", 2)}"
 
 SRC_URI = "${GNOME_MIRROR}/glib/${SHRT_VER}/glib-${PV}.tar.xz \
            file://configure-libtool.patch \
-           file://glib-2.0_fix_for_x32.patch \
            file://fix-conflicting-rand.patch \
-           file://Makefile-ptest.patch \
            file://add-march-i486-into-CFLAGS-automatically.patch \
-           file://run-ptest \
            file://glib-2.0-configure-readlink.patch \
+           file://run-ptest \
           "
 
 SRC_URI_append_class-native = " file://glib-gettextize-dir.patch"
 
-SRC_URI[md5sum] = "2f4b15f7ef43d8702d067ab987bf7aba"
-SRC_URI[sha256sum] = "f654d2542329012d8475736a165dfbf82fadf3ee940c2e0e6ddd4b2fde5cad7e"
+SRC_URI[md5sum] = "c50d2805a76763e9b4cc4385d4ea215d"
+SRC_URI[sha256sum] = "7513a7de5e814ccb48206340a8773ea523d6a7bf04dc74565de69b899bc2ff32"
 
 BBCLASSEXTEND = "native nativesdk"
 
 RDEPENDS_${PN}-ptest += "\
+            gnome-desktop-testing \
             tzdata \
             tzdata-americas \
             tzdata-asia \
index e57d2ac934ccdd8c0e4e104813a4ea5779e547c2..ad0671a770f1102c4437c2c160b850c39d8c041f 100644 (file)
@@ -27,9 +27,9 @@ S = "${WORKDIR}/glib-${PV}"
 
 CORECONF = "--disable-dtrace --disable-fam --disable-libelf --disable-systemtap --disable-man"
 
-PTEST_CONF = "${@base_contains('DISTRO_FEATURES', 'ptest', '--enable-modular-tests', '--disable-modular-tests', d)}"
+PTEST_CONF = "${@base_contains('DISTRO_FEATURES', 'ptest', '--enable-installed-tests', '--disable-installed-tests', d)}"
 EXTRA_OECONF = "--enable-included-printf=no ${CORECONF} ${PTEST_CONF}"
-EXTRA_OECONF_class-native = "${CORECONF} --disable-selinux --disable-modular-tests"
+EXTRA_OECONF_class-native = "${CORECONF} --disable-selinux"
 
 FILES_${PN} = "${libdir}/lib*${SOLIBS} ${datadir}/glib-2.0/schemas \
                ${datadir}/glib-2.0/gettext/mkinstalldirs ${datadir}/glib-2.0/gettext/po/Makefile.in.in"
@@ -37,10 +37,13 @@ FILES_${PN}-dev += "${libdir}/glib-2.0/include \
                     ${libdir}/gio/modules/lib*${SOLIBSDEV} \
                     ${libdir}/gio/modules/*.la"
 FILES_${PN}-dbg += "${datadir}/glib-2.0/gdb ${datadir}/gdb \
-                    ${libdir}/gio/modules/.debug"
+                    ${libdir}/gio/modules/.debug \
+                    ${libdir}/glib-2.0/installed-tests/glib/.debug"
 FILES_${PN}-codegen = "${datadir}/glib-2.0/codegen/*.py"
 FILES_${PN}-bash-completion = "${sysconfdir}/bash_completion.d \
                                ${datadir}/bash-completion"
+FILES_${PN}-ptest += "${libdir}/glib-2.0/installed-tests \
+                      ${datadir}/installed-tests/glib"
 
 ARM_INSTRUCTION_SET = "arm"
 USE_NLS = "yes"