]> code.ossystems Code Review - openembedded-core.git/commitdiff
cross-localedef-native_2.22.bb: Use autotools configure
authorTristan Van Berkom <tristan.vanberkom@codethink.co.uk>
Mon, 25 Apr 2016 20:36:26 +0000 (16:36 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 6 May 2016 09:30:58 +0000 (10:30 +0100)
Use the autotools default configure commands and just tell autotools
where to run configure from.

This fixes the build when running on an aarch64 host, which the prebuilt
configure scripts with glibc 2.22 do not recognize.

Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/glibc/cross-localedef-native_2.23.bb

index fa930fd480459e852a1b125121584173e3184f4f..a6795ed9b3529243bea06467e2269d6ed464fb13 100644 (file)
@@ -9,6 +9,10 @@ LIC_FILES_CHKSUM = "file://LICENSES;md5=e9a558e243b36d3209f380deb394b213 \
       file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
 
 
+# Tell autotools that we're working in the localedef directory
+#
+AUTOTOOLS_SCRIPT_PATH = "${S}/localedef"
+
 inherit native
 inherit autotools
 
@@ -47,11 +51,6 @@ S = "${WORKDIR}/git"
 EXTRA_OECONF = "--with-glibc=${S}"
 CFLAGS += "-fgnu89-inline -std=gnu99 -DIS_IN\(x\)='0'"
 
-do_configure () {
-       ${S}/localedef/configure ${EXTRA_OECONF}
-}
-
-
 do_install() {
        install -d ${D}${bindir}
        install -m 0755 ${B}/localedef ${D}${bindir}/cross-localedef