]> code.ossystems Code Review - openembedded-core.git/commitdiff
networkmanager: Add a method to stop network manager controlling selected network...
authorRichard Purdie <richard@openedhand.com>
Wed, 16 Jul 2008 08:35:51 +0000 (08:35 +0000)
committerRichard Purdie <richard@openedhand.com>
Wed, 16 Jul 2008 08:35:51 +0000 (08:35 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4843 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/networkmanager/files/allow-disabling.patch [new file with mode: 0644]
meta/packages/networkmanager/networkmanager_svn.bb

diff --git a/meta/packages/networkmanager/files/allow-disabling.patch b/meta/packages/networkmanager/files/allow-disabling.patch
new file mode 100644 (file)
index 0000000..10730e9
--- /dev/null
@@ -0,0 +1,45 @@
+Allow interfaces to be ignored by networkmanager by creation of a
+/etc/network/nm-disabled-INTERFACENAME file.
+
+RP - 16/7/2008
+
+Index: trunk/src/backends/NetworkManagerDebian.c
+===================================================================
+--- trunk.orig/src/backends/NetworkManagerDebian.c     2008-07-15 19:23:11.000000000 +0100
++++ trunk/src/backends/NetworkManagerDebian.c  2008-07-15 19:37:05.000000000 +0100
+@@ -29,6 +29,7 @@
+ #include <stdio.h>
+ #include <sys/types.h>
++#include <sys/stat.h>
+ #include <signal.h>
+ #include <arpa/inet.h>
+ #include "NetworkManagerGeneric.h"
+@@ -374,12 +375,25 @@
+ /*
+  * nm_system_device_get_disabled
+  *
+- * Return whether the distro-specific system config tells us to use
+- * dhcp for this device.
++ * Return whether the distro-specific system config tells us to interact
++ * with this device.
+  *
+  */
+ gboolean nm_system_device_get_disabled (NMDevice *dev)
+ {
++      struct stat statbuf;
++      gchar *filepath;
++
++      g_return_val_if_fail (dev != NULL, FALSE);
++
++      filepath = g_strdup_printf (SYSCONFDIR"/network/nm-disabled-%s", nm_device_get_iface (dev));
++
++      if (stat(filepath, &statbuf) == 0) {
++              g_free(filepath);
++              return TRUE;
++      }
++
++      g_free(filepath);
+       return FALSE;
+ }
index 58a15aaa244fdf93326b2b625d3ed500270209e9..0061bb28e94de3dfa3830a1d96fe12f24b5b8be7 100644 (file)
@@ -7,11 +7,12 @@ DEPENDS = "libnl dbus dbus-glib hal gconf-dbus wireless-tools ppp gnome-common"
 RDEPENDS = "hal wpa-supplicant iproute2 dhcp-client"
 
 PV = "0.7+svnr${SRCREV}"
-PR = "r6"
+PR = "r7"
 
 SRC_URI="svn://svn.gnome.org/svn/NetworkManager/;module=trunk;proto=http \
        file://no-restarts.diff;patch=1;pnum=0 \
         file://makefile-fix.patch;patch=1 \
+       file://allow-disabling.patch;patch=1 \
        file://NetworkManager \
        file://99_networkmanager"