]> code.ossystems Code Review - openembedded-core.git/commitdiff
lsof: clear setuid
authorKai Kang <kai.kang@windriver.com>
Sat, 27 May 2017 07:45:03 +0000 (15:45 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 29 May 2017 14:15:13 +0000 (15:15 +0100)
Having 'lsof' as a +s (setuid) binary could lead to security issues if
a compromise in the binary is found.  It is better that it be -s by
default as a precaution.

Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/lsof/lsof_4.89.bb

index b732cf0acd6aa3c2a06a517026e05404557bf699..650b34c7e2d7d68b9d01b181a0d7cbd376763811 100644 (file)
@@ -53,6 +53,6 @@ do_compile () {
 
 do_install () {
        install -d ${D}${sbindir} ${D}${mandir}/man8
-       install -m 4755 lsof ${D}${sbindir}/lsof
+       install -m 0755 lsof ${D}${sbindir}/lsof
        install -m 0644 lsof.8 ${D}${mandir}/man8/lsof.8
 }