]> code.ossystems Code Review - openembedded-core.git/commitdiff
sysvinit: make pidof usuable in a standalone setting
authorKoen Kooi <koen@dominion.thruhere.net>
Tue, 31 May 2011 09:19:04 +0000 (11:19 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 31 May 2011 11:44:38 +0000 (12:44 +0100)
Currently it's a symlink to killall5:

$ dpkg-deb -c sysvinit-pidof_2.88dsf-r1_armv7a.ipk  | grep pidof
lrwxrwxrwx root/root         0 2011-05-27 11:05 ./bin/pidof.sysvinit -> /sbin/killall5

The point of the pidof subpackage was to have a pidof without needing sysvinit, this restores that behaviour.

Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb

index 7d5e9366ecb4e39ffaea1a3e04c980b213bb6741..2cb650eab66003c49170983c49a8aa451511065e 100644 (file)
@@ -5,7 +5,7 @@ SECTION = "base"
 LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
                     file://COPYRIGHT;endline=15;md5=349c872e0066155e1818b786938876a4"
-PR = "r1"
+PR = "r3"
 
 # USE_VT and SERIAL_CONSOLE are generally defined by the MACHINE .conf.
 # Set PACKAGE_ARCH appropriately.
@@ -47,9 +47,11 @@ ALTERNATIVE_PRIORITY = "50"
 
 PACKAGES =+ "sysvinit-pidof sysvinit-sulogin"
 FILES_${PN} += "${base_sbindir}/* ${base_bindir}/*"
-FILES_sysvinit-pidof = "${base_bindir}/pidof.sysvinit"
+FILES_sysvinit-pidof = "${base_bindir}/pidof.sysvinit ${base_sbindir}/killall5"
 FILES_sysvinit-sulogin = "${base_sbindir}/sulogin"
 
+RDEPENDS_${PN} += "sysvinit-pidof"
+
 CFLAGS_prepend = "-D_GNU_SOURCE "
 export LCRYPT = "-lcrypt"
 EXTRA_OEMAKE += "'base_bindir=${base_bindir}' \