]> code.ossystems Code Review - openembedded-core.git/commitdiff
Sync various tweaks from OE, change default SRCREV policy to not auto increment rathe...
authorRichard Purdie <richard@openedhand.com>
Tue, 18 Dec 2007 15:04:06 +0000 (15:04 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 18 Dec 2007 15:04:06 +0000 (15:04 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3345 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/conf/bitbake.conf
meta/packages/autoconf/autoconf_2.61.bb
meta/site/common-glibc

index 218e80301c8986714e8d007ba1d34b5588be80be..20425d80502880c94012b9df169acb13f1b67576 100644 (file)
@@ -109,7 +109,18 @@ DATETIME = "${DATE}${TIME}"
 
 # python-native should be here but python relies on building 
 # its own in staging
-ASSUME_PROVIDED = "cvs-native svn-native bzip2-native diffstat-native patch-native python-native-runtime perl-native-runtime texinfo-native util-linux-native grep-native"
+ASSUME_PROVIDED = "\
+    bzip2-native \
+    cvs-native \
+    grep-native \
+    diffstat-native \
+    patch-native \
+    perl-native-runtime \
+    python-native-runtime \
+    svn-native \
+    texinfo-native \
+    util-linux-native \
+    "
 
 ##################################################################
 # Package default variables.
@@ -438,7 +449,7 @@ UPDATECOMMAND = "ERROR, this must be a BitBake bug"
 UPDATECOMMAND_cvs = "/usr/bin/env cvs -d${CVSROOT} update -d -P ${CVSCOOPTS}"
 UPDATECOMMAND_svn = "/usr/bin/env svn update ${SVNCOOPTS}"
 SRCDATE = "${DATE}"
-SRCREV = "${@bb.fetch.get_srcrev(d)}"
+SRCREV = "1"
 AUTOREV = "${@bb.fetch.get_srcrev(d)}"
 
 SRC_URI = "file://${FILE}"
@@ -511,9 +522,10 @@ AUTO_LIBNAME_PKGS = "${PACKAGES}"
 # when ${MACHINE} is 'ramses'. And finally '<foo>_local' overrides anything.
 #
 # This works for  functions as well, they are really just environment variables.
-#OVERRIDES = "local:${MACHINE}:${DISTRO}:${TARGET_OS}:${TARGET_ARCH}:build-${BUILD_OS}"
-# Alternative OVERRIDES to make compilation fail fast, we will enable it by default soon
+# Default OVERRIDES to make compilation fail fast in case of build system misconfiguration.
 OVERRIDES = "local:${MACHINE}:${DISTRO}:${TARGET_OS}:${TARGET_ARCH}:build-${BUILD_OS}:fail-fast:pn-${PN}"
+# Alternative OVERRIDES definition without "fail fast", usually only for native building and Scratchbox toolchains.
+#OVERRIDES = "local:${MACHINE}:${DISTRO}:${TARGET_OS}:${TARGET_ARCH}:build-${BUILD_OS}:pn-${PN}"
 
 ##################################################################
 # Include the rest of the config files.
@@ -536,7 +548,8 @@ require conf/sanity.conf
 DL_DIR ?= "${TMPDIR}/downloads"
 IMAGE_FSTYPES ?= "jffs2"
 PCMCIA_MANAGER ?= "pcmcia-cs"
-MACHINE_TASK_PROVIDER ?= "task-base"
+DEFAULT_TASK_PROVIDER ?= "task-base"
+MACHINE_TASK_PROVIDER ?= "${DEFAULT_TASK_PROVIDER}"
 IMAGE_ROOTFS_SIZE_ext2 ?= "65536"
 IMAGE_ROOTFS_SIZE_ext2.gz ?= "65536"
 IMAGE_ROOTFS_SIZE_ext3 ?= "65536"
index fe210a1003af962be2687007c36e1c8ae3bd497a..6b92dc8120e911f8ed98b097d333bfbb5fbc086c 100644 (file)
@@ -2,6 +2,8 @@ require autoconf.inc
 
 PR = "r1"
 
+PARALLEL_MAKE = ""
+
 DEPENDS += "m4-native"
 RDEPENDS_${PN} = "m4 gnu-config"
 
@@ -12,9 +14,3 @@ SRC_URI += "file://autoreconf-include.patch;patch=1 \
           file://autoheader-nonfatal-warnings.patch;patch=1 \
           file://config-site.patch;patch=1 \
           ${@['file://path_prog_fixes.patch;patch=1', ''][bb.data.inherits_class('native', d)]}"
-
-#
-# without it build break:
-# | make[1]: *** No rule to make target `../bin/autom4te', needed by `autoconf.in'.  Stop.
-#
-PARALLEL_MAKE = ""
index 362fe538cd992692c20a1ef2e5978544040adc0b..0ec53423f1188491ccf4ab63fd3054624e1e4e84 100644 (file)
@@ -37,3 +37,10 @@ ac_cv_func_pthread_attr_getstack=${ac_cv_func_pthread_attr_getstack=yes}
 ac_cv_func_getpagesize=${ac_cv_func_getpagesize=yes}
 ac_cv_func_memcpy=${ac_cv_func_memcpy=yes}
 ac_cv_func_strerror=${ac_cv_func_strerror=yes}
+
+# squid
+ac_cv_af_unix_large_dgram=${ac_cv_af_unix_large_dgram=yes}
+ac_cv_func_setresuid=${ac_cv_func_setresuid=yes}
+ac_cv_func_va_copy=${ac_cv_func_va_copy=yes}
+ac_cv_func___va_copy=${ac_cv_func___va_copy=yes}
+ac_cv_epoll_works=${ac_cv_epoll_works=yes}