]> code.ossystems Code Review - openembedded-core.git/commitdiff
matchbox-session-sato: Make the battery applet depend on machine features
authorEran Matityahu <eran.m@variscite.com>
Sun, 30 Jul 2017 15:24:19 +0000 (18:24 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 15 May 2018 09:00:31 +0000 (10:00 +0100)
matchbox-panel enables the battery plugin only if the
acpi/apm machine features are enabled,
so enable the battery applet in the session script
under the same conditions.

This avoids the 'Failed to load applet "battery"' warning at runtime,
in case these machine features are not defined.

Signed-off-by: Eran Matityahu <eran.m@variscite.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-sato/matchbox-sato/matchbox-session-sato/session
meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb

index f6313bdebe8933b51ed6f9b4181fb7eca13c8f75..3a70574af9d3aed0794ae20c2e762eb597f5c9d0 100644 (file)
@@ -20,7 +20,10 @@ matchbox-desktop &
 # doesn't have the feature "foo".
 
 START_APPLETS=showdesktop,windowselector
-END_APPLETS=clock,battery,$KEYBOARD_APPLET,systray,startup-notify,notify
+END_APPLETS=$KEYBOARD_APPLET,systray,startup-notify,notify
+END_APPLETS=battery,$END_APPLETS # feature-acpi
+END_APPLETS=battery,$END_APPLETS # feature-apm
+END_APPLETS=clock,$END_APPLETS
 END_APPLETS=openmoko-panel-gsm,$END_APPLETS # feature-phone
 
 matchbox-panel --start-applets $START_APPLETS --end-applets $END_APPLETS &
index d146e836d5278046875c658f24894fadb3f16a1a..8230e95140f6ad3692781523529cd4313d95b202 100644 (file)
@@ -26,7 +26,7 @@ FILES_${PN} += "${datadir}/themes/Sato/index.theme"
 
 do_install() {
        # This is the set of machine features that the script has markers for
-       FEATURES="phone"
+       FEATURES="acpi apm phone"
        SCRIPT="${S}/sedder"
        rm -f $SCRIPT
        touch $SCRIPT