]> code.ossystems Code Review - openembedded-core.git/commitdiff
quilt: add ac_cv_path_BASH to CACHED_CONFIGUREVARS also for native
authorMing Liu <ming.liu@windriver.com>
Thu, 23 Jan 2014 06:45:48 +0000 (14:45 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 2 Feb 2014 11:21:54 +0000 (11:21 +0000)
A issue was fixed in target recipe with commit: 95893404

[
    quilt: added ac_cv_path_BASH to CACHED_CONFIGUREVARS

    On Fedora 17, bash has moved to /usr/bin/bash and the configure process finds it
    on the host machine there, this ensures that it is set correctly for the target.

    [YOCTO #2363]

Signed-off-by: Saul Wold <sgw@linux.intel.com>
]

But it's also impacting native package in the case that the sstate is used
between Fedora 17(or later) and other hosts.

Signed-off-by: Ming Liu <ming.liu@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/quilt/quilt-0.61.inc
meta/recipes-devtools/quilt/quilt_0.61.bb

index f751ac83f3a8a79bfb2ce1f0592d817b11d744e6..19966c8389abb140ec6530280b196249cb8e8b75 100644 (file)
@@ -31,6 +31,8 @@ RDEPENDS_${PN} = "bash"
 EXTRA_OE_MAKE_ARGS_darwin ?= ""
 EXTRA_OE_MAKE_ARGS ?= "BUILD_ROOT=${D}"
 
+CACHED_CONFIGUREVARS += "ac_cv_path_BASH=/bin/bash"
+
 # quilt ignores DESTDIR
 do_install () {
        oe_runmake ${EXTRA_OE_MAKE_ARGS} install
index 565e46a39f47e248708a35c6e713f3e36dbdec49..3a08d13eafc58506dc85f40336d31d8a931fc77c 100644 (file)
@@ -5,8 +5,6 @@ SRC_URI += "file://aclocal.patch \
             file://gnu_patch_test_fix_target.patch \
            "
 
-CACHED_CONFIGUREVARS += "ac_cv_path_BASH=${base_bindir}/bash"
-
 # fix build-distro specific perl path in the target perl scripts
 do_install_append() {
        for perlscript in ${D}${datadir}/quilt/scripts/remove-trailing-ws ${D}${datadir}/quilt/scripts/dependency-graph ${D}${datadir}/quilt/scripts/edmail ${D}${bindir}/guards