]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa-demos: Specify the lib dir to locate glut libraries
authorDrew Moseley <drew_moseley@mentor.com>
Thu, 8 May 2014 20:17:41 +0000 (16:17 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 29 May 2014 12:42:10 +0000 (13:42 +0100)
(From OE-Core rev: 55ecbebdf13ef46f0fb4d87ef11651fe692be33d)

Signed-off-by: Drew Moseley <drew_moseley@mentor.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/mesa/mesa-demos/glut.patch
meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb

index 84b6d4f7f3de735417ed2807db1159d0cef83a1b..2ca5a938ac94ea443b5ea1c4127478ccdcb4285f 100644 (file)
@@ -27,7 +27,7 @@ Index: mesa-demos-8.0.1/configure.ac
 -              [glutInit],
 -              [],
 -              [glut_enabled=no])
-+       GLUT_LIBS="-L$withval/lib -lglut"],
++       GLUT_LIBS="-L$withval -lglut"],
 +      [GLUT_CFLAGS=""
 +       GLUT_LIBS="-lglut"]
 +        )
index 4bb92f4b0577a8b168da7db7055435d842bfb8e0..70ade94eecd351fec54fe78c0ef9e7576cf42267 100644 (file)
@@ -33,7 +33,7 @@ PACKAGECONFIG[freetype2] = "--enable-freetype2,--disable-freetype2,freetype"
 PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/libgl"
 PACKAGECONFIG[gles1] = "--enable-gles1,--disable-gles1,virtual/libgles1"
 PACKAGECONFIG[gles2] = "--enable-gles2,--disable-gles2,virtual/libgles2"
-PACKAGECONFIG[glut] = "--with-glut,--without-glut,"
+PACKAGECONFIG[glut] = "--with-glut=${STAGING_LIBDIR},--without-glut,"
 PACKAGECONFIG[osmesa] = "--enable-osmesa,--disable-osmesa,"
 PACKAGECONFIG[vg] = "--enable-vg,--disable-vg,virtual/libvg"
 PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,virtual/libgl wayland"