]> code.ossystems Code Review - openembedded-core.git/commitdiff
slang: specify --x-includes to pass qa sanity check
authorKevin Tian <kevin.tian@intel.com>
Fri, 18 Mar 2011 09:32:09 +0000 (17:32 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 18 Mar 2011 11:33:45 +0000 (11:33 +0000)
slang by default hardcodes a list of host dirs to search for X header
files, which may break qa sanity check. Use --x-includes to specify
sysroot as the fix.

Fix [YOCTO 907]

Signed-off-by: Kevin Tian <kevin.tian@intel.com>
meta/recipes-extended/slang/slang_2.2.2.bb

index f77a946c6ee495cf7f2e13d68f5c8ebaab8fdcbd..29d9e46d514c921757d45b849b2cd148f2bb4da8 100644 (file)
@@ -10,7 +10,7 @@ to recode S-Lang procedures in C if you need to."
 SECTION = "libs"
 PRIORITY = "optional"
 DEPENDS = "pcre"
-PR = "r1"
+PR = "r2"
 
 LICENSE = "GPL Artistic"
 LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
@@ -24,6 +24,7 @@ inherit autotools
 SRC_URI[md5sum] = "974437602a781cfe92ab61433dd16d03"
 SRC_URI[sha256sum] = "cfaf8551fa3855f9b0043309bb553ef6d457f931b404df5a6ba6a5a69371fc42"
 
+EXTRA_OECONF += " --x-includes=${STAGING_DIR_HOST}/usr/X11/include"
 do_install() {
        oe_runmake install DESTDIR=${D} -e 'INST_LIB_DIR=${STAGING_DIR_HOST}/usr/lib'
 }