]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3: Use addtask statement instead of task dependencies
authorTomasz Dziendzielski <tomasz.dziendzielski@gmail.com>
Mon, 25 Jan 2021 23:56:26 +0000 (00:56 +0100)
committerSteve Sakoman <steve@sakoman.com>
Thu, 4 Feb 2021 14:57:53 +0000 (04:57 -1000)
The externalsrc class deletes do_patch task which results with:
| ERROR: Task do_create_manifest in <PATH>/python3_3.8.2.bb depends upon
| non-existent task do_patch in <PATH>/python3_3.8.2.bb

Use addtask to define correct order to prevent this error, since addtask
mechanism accepts deleted tasks.

[YOCTO #14151]

Signed-off-by: Tomasz Dziendzielski <tomasz.dziendzielski@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit a746d034fa7eaad4f4876fa61c5a8c3c15e211c8)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-devtools/python/python3_3.8.2.bb

index a86542e5477144f4a670448f4dadcdef8069df21..a448b3ed9754dee0c4f715968e9a575f1e30ee19 100644 (file)
@@ -312,11 +312,8 @@ do_create_manifest() {
 }
 
 # bitbake python -c create_manifest
-addtask do_create_manifest
-
 # Make sure we have native python ready when we create a new manifest
-do_create_manifest[depends] += "${PN}:do_prepare_recipe_sysroot"
-do_create_manifest[depends] += "${PN}:do_patch"
+addtask do_create_manifest after do_patch do_prepare_recipe_sysroot
 
 # manual dependency additions
 RRECOMMENDS_${PN}-core_append_class-nativesdk = " nativesdk-python3-modules"