]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm: turn Berkeley DB hard dependency into PACKAGECONFIG
authorRoss Burton <ross@burtonini.com>
Mon, 17 May 2021 11:58:02 +0000 (12:58 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 18 May 2021 22:52:49 +0000 (23:52 +0100)
In the future we hope to switch to sqlite instead of Berkeley DB, so
prepare for this by adding an (enabled by default) PACKAGECONFIG for
Berkeley DB.

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/rpm/rpm_4.16.1.3.bb

index 2857cd730c45d273fe9c4a4eae364966ab1b458b..f9c04cf6807fa6c58bc673fbb95a68d5257dd589 100644 (file)
@@ -51,7 +51,7 @@ S = "${WORKDIR}/git"
 # included in 4.16.1.3
 CVE_CHECK_WHIETLIST += "CVE-2021-20271"
 
-DEPENDS = "libgcrypt db file popt xz bzip2 elfutils python3"
+DEPENDS = "libgcrypt file popt xz bzip2 elfutils python3"
 DEPENDS_append_class-native = " file-replacement-native bzip2-replacement-native"
 
 inherit autotools gettext pkgconfig python3native
@@ -74,11 +74,12 @@ EXTRA_OECONF_append_class-nativesdk = " --sysconfdir=/etc --disable-plugins"
 
 BBCLASSEXTEND = "native nativesdk"
 
-PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'inhibit', '', d)}"
+PACKAGECONFIG ??= "bdb ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'inhibit', '', d)}"
 # The inhibit plugin serves no purpose outside of the target
 PACKAGECONFIG_remove_class-native = "inhibit"
 PACKAGECONFIG_remove_class-nativesdk = "inhibit"
 
+PACKAGECONFIG[bdb] = "--enable-bdb,--disable-bdb,db"
 PACKAGECONFIG[imaevm] = "--with-imaevm,,ima-evm-utils"
 PACKAGECONFIG[inhibit] = "--enable-inhibit-plugin,--disable-inhibit-plugin,dbus"
 PACKAGECONFIG[rpm2archive] = "--with-archive,--without-archive,libarchive"