]> code.ossystems Code Review - openembedded-core.git/commitdiff
grub: Use COMPATIBLE_HOST
authorDarren Hart <dvhart@linux.intel.com>
Wed, 23 Nov 2011 23:17:16 +0000 (23:17 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 30 Nov 2011 22:21:53 +0000 (22:21 +0000)
Drop the anonymous python block in favor of the much simpler
COMPATIBLE_HOST mechanism.

Signed-off-by: Darren Hart <dvhart@linux.intel.com>
CC: Tom Zanussi <tom.zanussi@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-bsp/grub/grub_1.99.bb

index a077363426439b7e2ce042c9a8e7a2d1187b3a02..49c26f6fd1f4f9c685db82915a4e141b724f0804 100644 (file)
@@ -22,6 +22,8 @@ SRC_URI = "ftp://ftp.gnu.org/gnu/grub/grub-${PV}.tar.gz \
 SRC_URI[md5sum] = "ca9f2a2d571b57fc5c53212d1d22e2b5"
 SRC_URI[sha256sum] = "b91f420f2c51f6155e088e34ff99bea09cc1fb89585cf7c0179644e57abd28ff"
 
+COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'
+
 inherit autotools
 inherit gettext
 
@@ -31,13 +33,6 @@ do_configure() {
     oe_runconf
 }
 
-python __anonymous () {
-    import re
-    host = d.getVar('HOST_SYS', 1)
-    if not re.match('x86.64.*-linux', host) and not re.match('i.86.*-linux', host):
-        raise bb.parse.SkipPackage("incompatible with host %s" % host)
-}
-
 do_install_append () {
     install -m 0755 ${WORKDIR}/40_custom ${D}${sysconfdir}/grub.d/40_custom
 }