]> code.ossystems Code Review - openembedded-core.git/commitdiff
xproto: fix compilation with x32 toolchain
authorNitin A Kamble <nitin.a.kamble@intel.com>
Fri, 2 Dec 2011 20:20:07 +0000 (12:20 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 5 Dec 2011 22:45:22 +0000 (22:45 +0000)
Don't always define LONG64 for AMD64

X32 defines __amd64__/amd64 with 32bit long.  We should simply check
__LP64__ before defining LONG64 without checking __amd64__/amd64.

This fixes compilation with x32 toolchain.

Signed-Off-By: H.J. Lu <hjl.tools@gmail.com>
Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com> 2011/12/1
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/xorg-proto/xproto/xproto_fix_for_x32.patch [new file with mode: 0644]
meta/recipes-graphics/xorg-proto/xproto_7.0.22.bb

diff --git a/meta/recipes-graphics/xorg-proto/xproto/xproto_fix_for_x32.patch b/meta/recipes-graphics/xorg-proto/xproto/xproto_fix_for_x32.patch
new file mode 100644 (file)
index 0000000..c9fbb6f
--- /dev/null
@@ -0,0 +1,22 @@
+UpstreamStatus: Pending
+
+Don't always define LONG64 for AMD64
+    
+X32 defines __amd64__/amd64 with 32bit long.  We should simply check
+__LP64__ before defining LONG64 without checking __amd64__/amd64.
+
+This fixes compilation with x32 toolchain.
+
+Received this patch from H.J. Lu <hjl.tools@gmail.com>
+Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com> 2011/12/1
+
+--- xproto-7.0.22/Xmd.h.x32    2009-07-11 04:19:50.000000000 -0700
++++ xproto-7.0.22/Xmd.h        2011-11-30 17:14:19.290395893 -0800
+@@ -62,7 +62,6 @@ SOFTWARE.
+      defined(__ia64__) || defined(ia64) || \
+      defined(__sparc64__) || \
+      defined(__s390x__) || \
+-     defined(__amd64__) || defined(amd64) || \
+      defined(__powerpc64__)
+ #  define LONG64                              /* 32/64-bit architecture */
+ # endif
index 54f8482dce0c263fdeec339f2d28e66d59ab0441..8f763142ae53c4b4ec049f1bdc103de1e7e8699f 100644 (file)
@@ -8,9 +8,11 @@ System."
 LICENSE = "MIT & MIT-style"
 LIC_FILES_CHKSUM = "file://COPYING;md5=b9e051107d5628966739a0b2e9b32676"
 
-PR = "r0"
+PR = "r1"
 PE = "1"
 
+SRC_URI += "file://xproto_fix_for_x32.patch"
+
 EXTRA_OECONF_append = " --enable-specs=no"
 BBCLASSEXTEND = "native nativesdk"