]> code.ossystems Code Review - openembedded-core.git/commitdiff
kernel-devsrc: fix x86 (32bit) on target module build
authorBruce Ashfield <bruce.ashfield@gmail.com>
Wed, 5 Aug 2020 15:42:57 +0000 (11:42 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 6 Aug 2020 14:12:34 +0000 (15:12 +0100)
The previous devsrc v5.8 on target build fixup [532ae127c
kernel-devsrc: fix on-target module build for v5.8+], missed
on condition: the defconfig

On 32bit x86 the arch can be queried differently on the host
and target. We aren't building against the defconfig, so we
remove it from auto.conf.cmd and we can again prepare to build
modules on target.

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/kernel-devsrc.bb

index 0c98535f75810b3408db08e255a7b9daa307913a..6a606c3570f7e43b5f090c79342724d528307281 100644 (file)
@@ -263,6 +263,8 @@ do_install() {
         sed -i 's/ifneq "$(LD)" ".*-linux-ld.bfd.*$/ifneq "$(LD)" "ld"/' "$kerneldir/build/include/config/auto.conf.cmd"
         sed -i 's/ifneq "$(CC_VERSION_TEXT)".*\(gcc.*\)"/ifneq "$(CC_VERSION_TEXT)" "\1"/' "$kerneldir/build/include/config/auto.conf.cmd"
         sed -i 's/ifneq "$(srctree)" ".*"/ifneq "$(srctree)" "."/' "$kerneldir/build/include/config/auto.conf.cmd"
+        # we don't build against the defconfig, so make sure it isn't the trigger for syncconfig
+        sed -i 's/ifneq "$(KBUILD_DEFCONFIG)".*"\(.*\)"/ifneq "\1" "\1"/' "$kerneldir/build/include/config/auto.conf.cmd"
     fi
 
     # make the scripts python3 safe. We won't be running these, and if they are