]> code.ossystems Code Review - openembedded-core.git/commitdiff
opkg-utils: use multithreaded xz when building packages
authorRoss Burton <ross.burton@intel.com>
Mon, 19 Mar 2018 11:38:45 +0000 (11:38 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 20 Mar 2018 09:30:18 +0000 (09:30 +0000)
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/opkg-utils/opkg-utils/threaded-xz.patch [new file with mode: 0644]
meta/recipes-devtools/opkg-utils/opkg-utils_0.3.6.bb

diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils/threaded-xz.patch b/meta/recipes-devtools/opkg-utils/opkg-utils/threaded-xz.patch
new file mode 100644 (file)
index 0000000..13a49f9
--- /dev/null
@@ -0,0 +1,18 @@
+Pass --threads=0 to xz so that it will use as many threads as there are cores to compress the packages.  This makes qemu's do_package_ipk run in 34s instead of 275s on my machine.
+
+Upstream-Status: Inappropriate (ugly but works, discussing with upstream now)
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/opkg-build b/opkg-build
+index 0050c2b..93a7956 100755
+--- a/opkg-build
++++ b/opkg-build
+@@ -230,6 +230,8 @@ if gzip --help 2>&1 | grep -- "-T" > /dev/null; then
+ fi
+ if [ $compressor = "gzip" ] ; then
+       compressorargs=$zipargs
++elif [ $compressor = "xz" ] ; then
++      compressorargs="--threads 0"
+ fi
+ tsortargs=
index 081d8d8b7d3d09d31e986de5983fd9226e5d419f..0487c5f305933748f797c9d85c1a923789257654 100644 (file)
@@ -11,6 +11,7 @@ SRC_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/${BPN}/snapshot/${BPN}-${PV
            file://0001-Switch-all-scripts-to-use-Python-3.x.patch \
            file://0001-Only-use-sort-name-on-versions-of-tar-which-support-.patch \
            file://0002-opkg-build-Use-local-time-for-build_date-since-opkg-.patch \
+           file://threaded-xz.patch \
 "
 SRC_URI_append_class-native = " file://tar_ignore_error.patch"
 UPSTREAM_CHECK_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/refs/"