]> code.ossystems Code Review - openembedded-core.git/commitdiff
liblbxutil: Fix cross compile issues
authorRichard Purdie <rpurdie@linux.intel.com>
Wed, 31 Mar 2010 14:30:10 +0000 (15:30 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 31 Mar 2010 14:30:10 +0000 (15:30 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/xorg-lib/liblbxutil/mkg3states.patch [new file with mode: 0644]
meta/packages/xorg-lib/liblbxutil_1.1.0.bb

diff --git a/meta/packages/xorg-lib/liblbxutil/mkg3states.patch b/meta/packages/xorg-lib/liblbxutil/mkg3states.patch
new file mode 100644 (file)
index 0000000..029d761
--- /dev/null
@@ -0,0 +1,63 @@
+During the build process the mkg3states binary needs to be run. This patch
+allows it to be built with the build systems gcc allowing this to work.
+
+RP 31/3/10
+
+Index: liblbxutil-1.1.0/configure.ac
+===================================================================
+--- liblbxutil-1.1.0.orig/configure.ac 2009-12-04 22:52:04.000000000 +0000
++++ liblbxutil-1.1.0/configure.ac      2010-03-31 15:26:33.000000000 +0100
+@@ -50,4 +50,5 @@
+ AC_OUTPUT([Makefile
+          src/Makefile
++         src/image/Makefile
+          lbxutil.pc])
+Index: liblbxutil-1.1.0/src/Makefile.am
+===================================================================
+--- liblbxutil-1.1.0.orig/src/Makefile.am      2009-12-04 23:03:17.000000000 +0000
++++ liblbxutil-1.1.0/src/Makefile.am   2010-03-31 15:27:25.000000000 +0100
+@@ -3,10 +3,7 @@
+ AM_CFLAGS = $(CWARNFLAGS) $(LBXUTIL_CFLAGS)
+ INCLUDES = -I$(top_srcdir)/include
+-noinst_PROGRAMS = mkg3states
+-
+-mkg3states_SOURCES =                          \
+-      $(srcdir)/image/mkg3states.c
++SUBDIRS = image
+ liblbxutil_la_SOURCES =                               \
+       $(srcdir)/lbx_zlib/reqstats.h           \
+@@ -38,9 +35,8 @@
+ $(srcdir)/image/dfaxg42d.c: g3states.h
+-g3states.h: mkg3states
+-      -rm -f g3states.h
+-      $(AM_V_GEN) ./mkg3states -c > g3states.h_ && mv g3states.h_ g3states.h
++g3states.h: image/mkg3states
++      ./image/mkg3states -c > g3states.h_ && mv g3states.h_ g3states.h
+ liblbxutil_la_LDFLAGS = -version-number 1:0:0 -no-undefined
+Index: liblbxutil-1.1.0/src/image/Makefile.am
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ liblbxutil-1.1.0/src/image/Makefile.am     2010-03-31 15:26:33.000000000 +0100
+@@ -0,0 +1,15 @@
++# evil hack
++CFLAGS=$(CFLAGS_FOR_BUILD)
++CPPFLAGS=$(CPPFLAGS_FOR_BUILD)
++LDFLAGS=$(LDFLAGS_FOR_BUILD)
++
++CC=$(CC_FOR_BUILD)
++LIBTOOL = @LIBTOOL@ --tag=CC
++
++noinst_PROGRAMS = mkg3states
++
++mkg3states_SOURCES =                          \
++      mkg3states.c
++
++mkg3states_CFLAGS=$(CFLAGS_FOR_BUILD)
++mkg3states_LDFLAGS=$(LDFLAGS_FOR_BUILD)
index a148bae1186af063008d6e9e4ffd967cdf2e9060..cdf350924616bf0c5bef777dd96a1af8e6b6c5d1 100644 (file)
@@ -4,8 +4,8 @@ DESCRIPTION = "XFIXES Extension"
 DEPENDS += " libxext xextproto xproto zlib"
 PROVIDES = "lbxutil"
 PE = "1"
-PR = "r0"
+PR = "r1"
 
-#SRC_URI += "file://mkg3states.patch;patch=1"
+SRC_URI += "file://mkg3states.patch;patch=1"
 
 export CC_FOR_BUILD = "gcc"