]> code.ossystems Code Review - openembedded-core.git/commitdiff
pseudo: Drop patches merged into upstream branch
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 16 Dec 2020 16:54:26 +0000 (16:54 +0000)
committerSteve Sakoman <steve@sakoman.com>
Thu, 28 Jan 2021 14:41:47 +0000 (04:41 -1000)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 7386a116222979e6de60c39d2c094d5f216fb101)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-devtools/pseudo/files/0002-pseudo_client-Lessen-indentation-of-pseudo_client_ig.patch [deleted file]
meta/recipes-devtools/pseudo/files/0003-pseudo_client-Simplify-pseudo_client_ignore_path_chr.patch [deleted file]
meta/recipes-devtools/pseudo/pseudo_git.bb

diff --git a/meta/recipes-devtools/pseudo/files/0002-pseudo_client-Lessen-indentation-of-pseudo_client_ig.patch b/meta/recipes-devtools/pseudo/files/0002-pseudo_client-Lessen-indentation-of-pseudo_client_ig.patch
deleted file mode 100644 (file)
index e4a5356..0000000
+++ /dev/null
@@ -1,69 +0,0 @@
-From 28c760542eecd7c5b35ea88aa2b14d62afbda961 Mon Sep 17 00:00:00 2001
-From: Peter Kjellerstedt <pkj@axis.com>
-Date: Sat, 21 Nov 2020 17:22:38 +0100
-Subject: [PATCH] pseudo_client: Lessen indentation of
- pseudo_client_ignore_path_chroot()
-
-Change-Id: I739b18efb7a95ce2d2d907d0faf7df539ab9af1c
----
- pseudo_client.c | 45 +++++++++++++++++++++++++--------------------
- 1 file changed, 25 insertions(+), 20 deletions(-)
-
-diff --git a/pseudo_client.c b/pseudo_client.c
-index 116d926..a8bc3dc 100644
---- a/pseudo_client.c
-+++ b/pseudo_client.c
-@@ -1527,28 +1527,33 @@ int pseudo_client_ignore_fd(int fd) {
- int pseudo_client_ignore_path_chroot(const char *path, int ignore_chroot) {
-       char *env;
--      if (path) {
--              if (ignore_chroot && pseudo_chroot && strncmp(path, pseudo_chroot, pseudo_chroot_len) == 0)
--                      return 0;
--              env = pseudo_get_value("PSEUDO_IGNORE_PATHS");
--              if (env) {
--                      char *p = env;
--                      while (*p) {
--                              char *next = strchr(p, ',');
--                              if (!next)
--                                  next = strchr(p, '\0');
--                              if ((next - p) && !strncmp(path, p, next - p)) {
--                                      pseudo_debug(PDBGF_PATH | PDBGF_VERBOSE, "ignoring path: '%s'\n", path);
--                                      return 1;
--                              }
--                              if (next && *next != '\0')
--                                      p = next+1;
--                              else
--                                      break;
--                      }
--                      free(env);
-+
-+      if (!path)
-+              return 0;
-+
-+      if (ignore_chroot && pseudo_chroot && strncmp(path, pseudo_chroot, pseudo_chroot_len) == 0)
-+              return 0;
-+
-+      env = pseudo_get_value("PSEUDO_IGNORE_PATHS");
-+      if (!env)
-+              return 0;
-+
-+      char *p = env;
-+      while (*p) {
-+              char *next = strchr(p, ',');
-+              if (!next)
-+                      next = strchr(p, '\0');
-+              if ((next - p) && !strncmp(path, p, next - p)) {
-+                      pseudo_debug(PDBGF_PATH | PDBGF_VERBOSE, "ignoring path: '%s'\n", path);
-+                      return 1;
-               }
-+              if (next && *next != '\0')
-+                      p = next+1;
-+              else
-+                      break;
-       }
-+      free(env);
-+
-       return 0;
- }
diff --git a/meta/recipes-devtools/pseudo/files/0003-pseudo_client-Simplify-pseudo_client_ignore_path_chr.patch b/meta/recipes-devtools/pseudo/files/0003-pseudo_client-Simplify-pseudo_client_ignore_path_chr.patch
deleted file mode 100644 (file)
index a657a27..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-From a1d61d68777373a50ae23b9dd83b428abe2f748d Mon Sep 17 00:00:00 2001
-From: Peter Kjellerstedt <pkj@axis.com>
-Date: Sat, 21 Nov 2020 17:30:33 +0100
-Subject: [PATCH] pseudo_client: Simplify pseudo_client_ignore_path_chroot()
-
-This also plugs a memory leak by making sure env is freed.
-
-Change-Id: Ia8635fd2c6b1e85919e4743713a85e0b52c28fac
----
- pseudo_client.c | 21 ++++++++++-----------
- 1 file changed, 10 insertions(+), 11 deletions(-)
-
-diff --git a/pseudo_client.c b/pseudo_client.c
-index a8bc3dc..7dc0345 100644
---- a/pseudo_client.c
-+++ b/pseudo_client.c
-@@ -1538,23 +1538,22 @@ int pseudo_client_ignore_path_chroot(const char *path, int ignore_chroot) {
-       if (!env)
-               return 0;
-+      int ret = 0;
-       char *p = env;
--      while (*p) {
-+      while (p) {
-               char *next = strchr(p, ',');
--              if (!next)
--                      next = strchr(p, '\0');
--              if ((next - p) && !strncmp(path, p, next - p)) {
--                      pseudo_debug(PDBGF_PATH | PDBGF_VERBOSE, "ignoring path: '%s'\n", path);
--                      return 1;
--              }
--              if (next && *next != '\0')
--                      p = next+1;
--              else
-+              if (next)
-+                      *next++ = '\0';
-+              if (*p && !strncmp(path, p, strlen(p))) {
-+                      pseudo_debug(PDBGF_PATH | PDBGF_VERBOSE, "ignoring path: '%s'\n", path);
-+                      ret = 1;
-                       break;
-+              }
-+              p = next;
-       }
-       free(env);
--      return 0;
-+      return ret;
- }
- int pseudo_client_ignore_path(const char *path) {
index a9f7aa966a9e3d15491a1321c8008116e6d143d0..78c6b01f094f6cc1d6c89ae686d2996bbb763f7f 100644 (file)
@@ -4,11 +4,9 @@ SRC_URI = "git://git.yoctoproject.org/pseudo;branch=oe-core \
            file://0001-configure-Prune-PIE-flags.patch \
            file://fallback-passwd \
            file://fallback-group \
-           file://0002-pseudo_client-Lessen-indentation-of-pseudo_client_ig.patch \
-           file://0003-pseudo_client-Simplify-pseudo_client_ignore_path_chr.patch \
            "
 
-SRCREV = "69f205c41902e17933b81b1450636848e8da2126"
+SRCREV = "6fd57da7b1de1a2b6cf530e336d58bb5f8bdd015"
 S = "${WORKDIR}/git"
 PV = "1.9.0+git${SRCPV}"