]> code.ossystems Code Review - openembedded-core.git/commitdiff
lighttpd: Add systemd support
authorMuhammad Shakeel <muhammad_shakeel@mentor.com>
Wed, 4 Sep 2013 11:05:00 +0000 (11:05 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 10 Sep 2013 22:13:33 +0000 (23:13 +0100)
- Remove dependency on meta-systemd

Signed-off-by: Muhammad Shakeel <muhammad_shakeel@mentor.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/lighttpd/files/lighttpd.service [new file with mode: 0644]
meta/recipes-extended/lighttpd/lighttpd_1.4.32.bb

diff --git a/meta/recipes-extended/lighttpd/files/lighttpd.service b/meta/recipes-extended/lighttpd/files/lighttpd.service
new file mode 100644 (file)
index 0000000..66a907a
--- /dev/null
@@ -0,0 +1,12 @@
+[Unit]
+Description=Lightning Fast Webserver With Light System Requirements
+After=network.target
+
+[Service]
+ExecStartPre=@SBINDIR@/lighttpd -t -f @SYSCONFDIR@/lighttpd.conf
+ExecStart=@SBINDIR@/lighttpd -D -f @SYSCONFDIR@/lighttpd.conf
+ExecReload=@BASE_BINDIR@/kill -HUP $MAINPID
+
+[Install]
+WantedBy=multi-user.target
+
index 6635e31167597652407d85827e2df320be89b356..c24349468634bd09dc593814aa0640edef8480ac 100644 (file)
@@ -22,6 +22,7 @@ SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.t
         file://index.html.lighttpd \
         file://lighttpd.conf \
         file://lighttpd \
+        file://lighttpd.service \
         "
 
 SRC_URI[md5sum] = "8e2d4ae8e918d4de1aeb9842584d170b"
@@ -39,16 +40,25 @@ EXTRA_OECONF = " \
              --disable-static \
 "
 
-inherit autotools pkgconfig update-rc.d gettext
+inherit autotools pkgconfig update-rc.d gettext systemd
 
 INITSCRIPT_NAME = "lighttpd"
 INITSCRIPT_PARAMS = "defaults 70"
 
+SYSTEMD_SERVICE_${PN} = "lighttpd.service"
+
 do_install_append() {
        install -d ${D}${sysconfdir}/init.d ${D}/www/logs ${D}/www/pages/dav ${D}/www/var
        install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
        install -m 0755 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
        install -m 0644 ${WORKDIR}/index.html.lighttpd ${D}/www/pages/index.html
+
+       install -d ${D}${systemd_unitdir}/system
+       install -m 0644 ${WORKDIR}/lighttpd.service ${D}${systemd_unitdir}/system
+       sed -i -e 's,@SBINDIR@,${sbindir},g' \
+               -e 's,@SYSCONFDIR@,${sysconfdir},g' \
+               -e 's,@BASE_BINDIR@,${base_bindir},g' \
+               ${D}${systemd_unitdir}/system/lighttpd.service
 }
 
 FILES_${PN} += "${sysconfdir} /www"