]> code.ossystems Code Review - openembedded-core.git/commitdiff
nativesdk-coreutils: a lot of warnings fixed
authorDengke Du <dengke.du@windriver.com>
Wed, 16 Mar 2016 02:49:13 +0000 (22:49 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 23 Mar 2016 21:49:58 +0000 (21:49 +0000)
When we create nativesdk-coreutils, a lot of warnings appear,it
show many files can't find. Because in the coreutils recipe, it
didn't contain the do_install for the nativesdk, so when the
alternative system check the files in the following process, it
can't find the files. So we should add the do_install for the
nativesdk, change the function do_install_append_class-target() to
do_install_append() in the file:
meta/recipes-core/coreutils/coreutils_8.25.bb
in this way, the alternative system can find the files, the warnings
disappear.

Signed-off-by: Dengke Du <dengke.du@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/coreutils/coreutils_8.25.bb

index b875b18f9c9f5be1c1b0f9ea2f1871f0d21ab88c..419a693372c9bc817503ebfbc8fd35a38f5c9b67 100644 (file)
@@ -28,6 +28,7 @@ SRC_URI[manpages.sha256sum] = "2ee31c3a6d2276f49c5515375d4a0c1047580da6ac1053689
 
 EXTRA_OECONF_class-native = "--without-gmp"
 EXTRA_OECONF_class-target = "--enable-install-program=arch --libexecdir=${libdir}"
+EXTRA_OECONF_class-nativesdk = "--enable-install-program=arch"
 
 # acl and xattr are not default features
 #
@@ -68,7 +69,7 @@ do_compile_prepend () {
        mkdir -p ${B}/src
 }
 
-do_install_append_class-target() {
+do_install_append() {
        for i in df mktemp base64; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${BPN}; done
 
        install -d ${D}${base_bindir}