]> code.ossystems Code Review - openembedded-core.git/commitdiff
mktemp: add mktemp package
authorYu Ke <ke.yu@intel.com>
Thu, 29 Jul 2010 02:40:15 +0000 (10:40 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 19 Aug 2010 11:36:37 +0000 (12:36 +0100)
Mktemp is a small program to allow safe temporary file creation from shell scripts. this commit add mktemp 1.7.

it is borrowed from open embedded with following changes:
- upgrade from 1.6 to 1.7
- remove the patch add_destdir.patch, since this patch is already included in 1.7.

Signed-off-by: Yu Ke <ke.yu@intel.com>
meta-lsb/packages/mktemp/files/disable-strip.patch [new file with mode: 0644]
meta-lsb/packages/mktemp/mktemp_1.7.bb [new file with mode: 0644]

diff --git a/meta-lsb/packages/mktemp/files/disable-strip.patch b/meta-lsb/packages/mktemp/files/disable-strip.patch
new file mode 100644 (file)
index 0000000..d6bc528
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/Makefile.in b/Makefile.in
+index 37b3cc9..f1026f3 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -95,7 +95,7 @@ install-dirs:
+           $(DESTDIR)$(mandir)/man1
+ install-binaries: $(PROG)
+-      $(INSTALL) -m 0555 -s $(PROG) $(DESTDIR)$(bindir)/$(PROG)
++      $(INSTALL) -m 0555 $(PROG) $(DESTDIR)$(bindir)/$(PROG)
+ install-man:
+       $(INSTALL) -m 0444 $(srcdir)/mktemp.$(mantype) \
diff --git a/meta-lsb/packages/mktemp/mktemp_1.7.bb b/meta-lsb/packages/mktemp/mktemp_1.7.bb
new file mode 100644 (file)
index 0000000..a348274
--- /dev/null
@@ -0,0 +1,26 @@
+DESCRIPTION = "Allow safe temporary file creation from shell scripts."
+HOMEPAGE = "http://www.mktemp.org/"
+BUGTRACKER = "http://www.mktemp.org/bugs"
+SECTION = "console/utils"
+LICENSE = "ISC style"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=430680f6322a1eb87199b5e01a82c0d4"
+
+PR = "r0"
+
+SRC_URI = "ftp://ftp.mktemp.org/pub/mktemp/${P}.tar.gz \
+        file://disable-strip.patch \
+        "
+
+inherit autotools update-alternatives
+
+EXTRA_OECONF = "--with-libc"
+
+do_install_append () {
+       mkdir ${D}${base_bindir}
+       mv ${D}${bindir}/mktemp ${D}${base_bindir}/mktemp.${PN}
+}
+
+ALTERNATIVE_NAME = "mktemp"
+ALTERNATIVE_LINK = "${base_bindir}/mktemp"
+ALTERNATIVE_PATH = "${base_bindir}/mktemp.${PN}"
+ALTERNATIVE_PRIORITY = "100"